Bans not working correctly (Solved)

I may be tired but I’m not dumb :joy:
A regular user does not have ban omission and if @EnigmaPatrick saw it broken too then theres not much left for me to say.

@FakE nope, standard database shipped with TeamSpeak - nothing in logs to suggest db is broken either.

Never said you were dumb, just have to remember we provide support for all skill levels and even pros over look simple things sometimes.

So SQLite.

Its calm,I get ya.
Didnt even read properly to realise @FakE asked to specify.

I wanna wait and see if any forum admins have any ideas and see if theres anything we can come up with .

Thanks for all the help though :heart:

I would like to think this is not a corrupt database fault, theres usually no recovering from that is there :sweat_smile:

I’ve done it, But I’m sure my database was not as large as yours. (mine is only 709,632 bytes after +10 years)

I will try your methodology out in the morning on a test server to avoid messing up the real thing.

I would like to think not!!! :joy::joy:

@FakE Why would you be writing any of this while driving? :confused:

@Pantoflarz Have you restarted your server since? Your regex ban is still working.

Have you tried testing your IP bans with someone you actually know, by banning their IP and have them confirm if it’s working or not?

I highly doubt this is anything to do with database corruption currently, just likely an oddity with the TeamSpeak client and saving the ban to the server (Possibly a connection, idk).

My TS database is now 62MB+ and I’ve never seen an issue like this, only when human error is the cause.

1 Like

Beside the off-topic. Tnx for the report.

I can reproduce this on the server you mentioned and i can change it in the client so that i get banned.
Need to investigate on our system.

1 Like

I fail to reproduce this on local system and now i fail to replicate this on mentoined server either.
What permissions do i have when i connect and get group “Nowy / a na FlameSpeak!” ?

When i get group “Zarejestruj Się!” i get banned again.
So i guess the group i have on first connect has ignore ban set.

1 Like

I haven’t restarted no, everything is the same.

I would hope so

//edit - checked our database and its only 40mb in size and the IP banning is something I will probably test out tommorow with some friends, I will try the different ban entry methods and stuff too - though I wonder if since I’ve re-done the permissions and the nickname ban seems fixed, if that will also fix this.

No groups apart from Admins have the ignore ban permission set. However, I do remember that back in the day the “ Nowy / a na FlameSpeak! ” did have ban omissions to help our music bots out. This was months ago though and was removed soon after.

For clarities sake and my own peace of mind and to prevent you searching for a bug that may not exist, I re-did the permissions from scratch on both those groups and it seems the problem is now fixed - a new identity is banned, as is a client with the


Still confused what the problem was here though, feels like I’m going mad or something :frowning:

I get that we’re trying every possibility but yes, its all been the same for years and hasn’t been touched and all is correct.