Can't close Settings after Update to Beta 75

System: MacOS Sonoma 14.0
TS5 Version: 5.0.0-beta75
TS5 Build Number: 1696607978

After updating to the specified version above, I encountered an issue where I couldn’t close the settings once opened. Temporarily reverting to v74 resolved the issue, but the client auto-updates to the latest version, making this a short-term solution.

1 Like

Tried that but works fine (even after several tries and client restarts).
Settings do close by clicking the X or any other part in client.


I did see the same problem!
However, it only occurred when I was in VR. I could interact with everything in the TeamSpeak client through the Steam VR overlay apart from closing the settings. So something is definitely behaving weirdly there!
I hesitated to report this as I thought it to be just some VR quirks. But now seeing someone else with the exact same problem suggests there to be more.
@TS.ChrisR It would be nice if you could just check if this button behaves somehow differently from all other buttons.

I temporarily resolved the issue by switching from my audio interface to the default interface, which allowed me to close the settings. However, once I revert to the USB interface, the problem recurs and I can’t exit.

1 Like

That’s interesting. When in VR Windows automatically switches to the USB interface for the HMD. I will test this tomorrow evening and report back.

Got the same problem, but on Windows 11.
TS5 V. 5.0.0-beta75
TS5 build: 1696607978

I have to open audio settings each time I use TS5 to turn off and on VAD every time I launch TS5, If not I will have open mic all the time. Also a bug…
But now I cannot close Settings after opening settings (don’t have to change anything, just open).
Clicking Cogwheel or X next to settings heading does nothing.
I have tried reinstall, no change.

The closing Settings issue happened after one of the latest Win updates a couple of days ago…

I uninstalled TS5 and installed it again.
This fixed the “not closing settings” for me.

EDIT: Stopped working after about 10 minutes… Can’t close settings again…

1 Like

What menu in the options is open when it won’t close?
Or does it happen on any menu (like About) dialog?

I guess you have a virtual audio device (any audio external audio interface) installed and connected?

1 Like

I’m using a USB Audio interface and face the same “open mic” issue as @HotRod. Toggling the VAD setting resolves the mic issue but traps me in the settings. While I can navigate through settings, I can’t exit.

@HotRod: The Client auto-updates, reverting to the problematic version.

A workaround that works for me is switching the audio devices from my interface to the default device. This currently resolves both the “open mic” and “settings trap” issues.

So it won’t close in any menu in the settings or just when audio is selected? Your reply isn’t clear to me.

That you use a device with virtual audio cards/channels (a interface for audio) was already clear to me :slight_smile:

1 Like

Any menu.
As soon as I enter the settings, I’m no longer able to leave until I switch to the default audio device in the audio settings.

1 Like

We can reproduce the issue now.

Our how to is to disable all audio devices on Windows and then use the client (+ it will crash once after removing devices).


Hi, I downloaded the beta76 today and there the same issue appears. In the beta 75 version it was possible to go out the settings by clicking the teamspeak logo, but with the newer version it is not possible to go out of the settings.
Thats really bad, because as written before I have to go to the settings every time, otherwise my mic will be on the whole time.
Thank you for checking!
Regards, Felix

1 Like

Since updating to version 5.0.0-beta76 i cannot close the settings on ts5. The “X” doesn’t work for me.

Version: 5.0.0-beta76
Build Number: 1698243642
System: Win11 22h2

1 Like

I have the same issue as @HotRod & @Drechim

I use an Elgato WaveLink and their software to apply FX to the microphone. So in TS my capture device is set to use a virtual audio device.

On each launch of TS I need to enter the settings and turn off and then re-enable VAD. Otherwise my microphone will remain on constant broadcast in TS.

I’ve been doing the above steps for months. But with the recent bug of being unable to close the settings menu once opened. has made this issue even more annoying than before. The only way to get back to the server is to restart the application in full. Which then requires going back into the menu for VAD…

1 Like

I also have the same problem with the latest update beta 76. It only lets you exit on default. If i just close the program after choosing the BT60 headset which is what i use. I reopen the teamspeak to find that i get a gargled audio sound with stuttering with not just what people say but with all my audio. Its like a buffering problem with this stutter. I close the TS and it goes back to normal.

When I open TS client 5, click on Settings → change capture device for Microphone, want to close the settings → no luck whatsover. The button with a little cross just stops working completely…

So weird. I’ve had this issue for a few weeks, and figured it might have been an issue with my OS. Since I’m on Linux, I figured it’s a weird bug because I grabbed my TS off of the AUR. But nope, glad to see it’s not just a me thing.

Either way, this fixed it. Changing my capture device from my dedicated mic to default device works fine, and allows me to go back to using volume gate settings, and not an open mic. Super weird, I guess it’s some hangup inside TS where it can’t save settings specific to the device selected.

We have a potential fix ready for beta 77.

Our Alpha testers can use upcoming rc3 and leave feedback.