Email adress change - system ain't working

Hello there,

I’m experiencing a problem changing my email address.
I enter the new adress in the “My Account” section after I logged in .
I get the first mail to the old adress and confirm it.
I get the second mail to the new adress and confirm it.
I get to the step where I enter the password and click on submit.
Just nothing happens, no matter what time I wait. It doesn’t take me further on. I also tried doing so with Firefox and Google Chrome, so its not a browserproblem.
Though, when trying to “reset” my password for the new mailadress it says there is a tranferring pending. So the system has the infos, just doesn’t seem to process it further on.
Additionally, since I tried changing the mail first, my TS profile can’t be completely loaded in TS, resulting in me sometimes havings no favourite servers, nor right on’em a.s.o.
When I contacted support on it, I was directed to this forum, so here we are.

I’d highly appreciate some kind of solution here.

Best regards
Kio Boid

I changed my email address today via MyTeamspeak.com using the “Change Email” button.

https://www.myteamspeak.com/userarea/my/change-email


To see the change on community.teamspeak you have to LogOut and login with the new email address. You account will then show the new email address.

Yep system is working fine.
Just changed my email.

The step where you enter the password was the last step.
Now you must login with new email and old password.

2 Likes

Well,

system doen’t work for me:


This is where I get. clicking on submit doesn’t do anything. The submit button turns gray for a few seconds, thats it. Turns back blue, no response.


This is, what I get when trying to login with the new mail and old password.


This happens, when I try to reset the pw for the new mail.

And last but not least:


I can’t initiate the mailchange again, as it states the mailaddress is already taken.

And for the love of god I even tried using microsoft edge, still -same unpleasent result.

Any ideas on this?

When a email change wasn’t finished. Then this process is locked 48 hours till you can start a new e-mail change.

You must finish the first change or wait 48 hours till you can retry.

The system clearly works. Double check that the verification link you got in first place is fine when copied into a browser.

3 Likes

Well,

the link -i copied it, I clicked on it and I also typed it in manually. As the screenshot proofes I get to your website. I can click on submit. As I said, it turns grey for a few seconds, then blue again.
Here, have a video of it:

I tried four different browsers and also on my VM.

The password is saved for login. I also inserted it manually. But since there is no resonse at all, I’d guess, the system is not working just fine.

Cheers

  • Please wait 48 hours (since first try) and then try again.
  • Make sure your browser or addblocker / pihole etc. do not block contetnt which is needed.

Edit we checked your account and URL you got in second email. Nothing suspicious in there.


It is working fine.
Edit our system shows that there are some users who changed their emails the last days. Edit End

You got 2 people telling you email change worked. One of them is an user like you and answered before i did.

It’s fine if you ignore my test… but i got no special setup to test that (just normal Chrome or Firefox without blocking content from our websites).

1 Like

Mate,

neither I’m ignoring your test nor somebody elses.
It’s working for you guys, thats nice. You run a test on the system itself and its working. I get that.
I’m not dumb. All I’m saying is, it is not working for me.

I installed the opera chrome just today to test. I have no blockers in it or something else, granted full right for the website, still, all I get is shown in the video.

So either I’m just to dumb, or the system/ site ain’t working properly (for me).

Since it seems that I already lost the content of my account in the client, I’ll just set up a new identity, wait for 48h until the running process is terminated and register a fully new account to then connect to the identity.

Thank you for the attempt to help out, dunno what it is after all. I give up.

Cheers.

After you initiated it for the first time you should have received an email on the old address requiring you to confirm the change. Did you get this email and did you follow the link in it?

We are not thinking that you are dumb or anything like that.

I just argue that there is nothing wrong on our side. That’s all.

Whaaat?

A change of email no matter if finished or not does not touch your synced data.
And you can not reset your password while a change is ongoing.

So your old data must be there with old email and password as login.

By any chance?
Did you reset your password before you tried to change your email?
If yes, did you use a recovery key in client or made fallback or did you even start a client after the password reset?

Would say yes or first description would not match that perfect in steps :slight_smile:

3 Likes

When trying to change email on https://www.myteamspeak.com/, I successfully verified my primary email and the new email address. However, on the page where I am required to input my current password, nothing would happen when I was clicking on the “submit” button. Multiple browsers tried, including Edge and Chrome. Needs help!

Make sure, you don’t use any adblockers or plugins, which might block anything from the website.

I was trying to change the address with adblockers disabled, but now when I tried to click on the URL sent to the new email address, titled “myTeamSpeak Email Change Validation”, the webpage reports:

Error
The current address was already validated for a past process.

However, the email related to my account hasn’t been updated.

When I tried to start another changing email process, the webpage reports:

Error
The desired address “xxx” is already taken by another account or user.

You cannot start a new email change for 48 hours as long the old process wasn’t completed by you.

1 Like

I am getting the same error as @EthanMX

  • I to go myTeamSpeak
  • I enter all the details
  • I confirm my old email address
  • I confirm the new email address
  • I input my current password
  • Nothing happens when I click “Submit”

To check if my browser even send data to the server I checked the “Network”-Tab in the “Web Developer Tools” and there I see the following error:
“Uncaught Object { toString: toString(), message: “gcm: tag doesn’t match” }” at “thirdparty.js:7:28443

I tried to change my password on two different machines with two different browsers and every script blocker or ad blocker disabled. I even waited more than 48 hours between tests.

We are looking into your account.

I will reply when I know more.

1 Like

I tired again today but still failed to change the email address. Same issue as @TheJ3st3r. Everything goes well until nothing happens when clicking “submit”.

Same “Uncaught” rrror in web-dev console. On Chrome with all entensions disabled.