Error at the first start: "./ts3server_startscript.sh: line 103: readlink: command not found"

Hello,

i am trying to install my own private teamspeakserver on an Debian 9 server. I have downloaded the zip, unpacked this and now i try to start the ts3 server. But i become the following error:

 [email protected]:~/teamspeak3-server_linux_amd64$ ./ts3server_startscript.sh start
./ts3server_startscript.sh: line 103: readlink: command not found
dirname: missing operand
Try 'dirname --help' for more information.
Starting the TeamSpeak 3 server
Could not find binary, aborting

Can someone help or can me say what i have todo?

Best regard.

Hi, if you want to Install a TeamSpeak Server on Debian 9 this Guide
could help you: https://steamforge.net/wiki/index.php/How_to_setup_a_Teamspeak_3_Server_under_Debian_9

Maybe you forgot some staps or add the User as sudo not sure.
At which tutorial you tried to orientate and what did you paste in the Terminal?


Additional things:

  • You tried to re-download the Files?
  • Do you runend ts3server_minimal_runscript.sh before?
1 Like

Thanks for this link, but it read like my tutoral that i used before (it´s a german written tutorial, but it is nearly the same):
https://www.bennetrichter.de/anleitungen/teamspeak3-server-linux/

yes with this, 3 times.

No.

Additional information: It is not a root server or a server where i have sudo power, it is an managed server from a hoster, so i can´t move the files in the /opt/ directory, so i leave it in the home dir from my shell-user. I know that teamspeak musst run under this server, I know persons which have the same server(-package/setup).

Thanks and best regards, Laberkopf

Your server OS does not provide readlink command, which the start script relies on.
Contact your managed hosting provider to install the necessary package.
Pretty much on every linux distro it is coreutils.

2 Likes

Hello @Škýl,

yes, that was the problem, after my hoster has install the package, the server starts. Thanks!

Best regards, Florian

1 Like
twitch instagram twitter facebook