I am having problems (Solved)

Hey i am having issues with my TS server i can join with my ipv4 but that is a private network so my domain company cant put a private IP in my Domain Ragemalik.com i cant use my public ip to join my TeamSpeak What can i do? this is the ip 192.168.0.52 would you mind testing it from a different IP? Please tell me if it works and how i can impliment my public ip for my TeamSpeak server

Nobody outside your network will be able to join your private IP range.

There’s nothing you have to do to set up the server using your public IP address.
But you need to allow TeamSpeak to pass your firewall and it’s needed to open/forward the required ports clients need to connect to your server.

Service Protocol Local Port (Server) Required?
Voice UDP 9987 Yes
Filetransfer TCP 30033 Yes

How to allow TeamSpeak to pass your firewall depends on the OS system your server’s running on.


If you wan’t to use your domain name ragemalik.com to let clients join your server using it, you will have to setup SRV records or simply add an A(AAA) record pointing to your server IP address if you have one TeamSpeak server only using the default port 9987.

image IS that all i need to do? I am also on windows 10 64bit

Just as note, you can edit your posts instead of deleting them and creating a new one.

For me this looks like the Windows firewall settings.
Please note, the TeamSpeak client doesn’t need to be added to the (incoming) firewall rules.

It’s not required to check both checkboxes for public and private network types but it’s okay.

Do you have more than one TeamSpeak server installed on your PC?
If not just hit details on the records and remove the old one to keep the firewall clean.


And yes in case of Windows servers this method to allow TeamSpeak to pass the firewall is okay.

Hey,

Sorry i did not know that i also dont have another server but i dont know which is it i dont want to delete the right one i have just tried to use my public ip and it did not work

and sorry i need to do another post because i keep on pressing reply to the thread instead to you and i think it will not give you a notification if i did not reply to you.

It doesn’t matter if you reply to the thread or to me. The result is the same.

Since your OS is Windows 10 I assume you try to host your TeamSpeak server at home.
If so you will need to forward the required ports of TeamSpeak to your PC in your router as well.
(mentioned the ports above)

Your router is pretty much your 2nd firewall which needs to be adjusted.

  • forward incoming port 9987 UDP to your PC, target port 9987
  • forward incoming port 30033 TCP to your PC, tartget port 30033

This needs to be done if you host your TeamSpeak server at home.

Sorry about that

Do I do this in the inbound and outbound rules in the firewall? Or do I need to access my WIFI settings? I have added the rules for the outbound and inbound if that’s what you are talking about

The rules are incoming (aka. inbound) rules.
You PC which is running the TeamSpeak server has it’s own firewall - the Windows firewall.
You have to allow TeamSpeak to pass this firewall as you already did.
(step 1 completed)

Incoming connections from outside your network will at first “knock” on your router’s firewall door.

Your router is the firewall for your whole private network.
To allow incoming external requests for the port 9987 and 30033 you will have to forward these ports to your PC your TeamSpeak server’s running on.

That’s step 2.

That’s just an example image how “common” port forwarding settings in routers look like.
(the rule for port 10011 can be ignored for your case)


What you need to do right now is to acces and open your router settings, navigate to the port opening/forwarding category and add two new rules to forward the ports 9987 UDP and 30033 TCP as mentioned above.

I am currently doing that 1min

i have now done that is this all?

Thank you sooo much! it worked!!!

1 Like

I have one more question if you would mind answering

I have roles (server groups) so i have a YT group the join power is higher than the Clan group so people with the YT role can join the Clan VC because YT has a higher Join power

As mentioned above it’s not required to forward the port 10011 (for external query access).

I assume you’re talking about the i_channel_join_power.

Yes if the required join_power of a channel is less or equal of your join_power defined in your group (role) you can enter the channel.

If the required join_power is higher than your join_power (of your group) you can’t join the channel.

This means if your YT group has a join_power of 50 for example and the required join_power of the channel is 25 (equal to the join_power of your Clan group) your YT group will be able to join this channel as well as the Clan group.

is there a way the YT rank cant join Clan even though the join power on the channel is set to a lower leven then the YT ranks join power? @FakE

twitch instagram twitter facebook