(Instance) Error opening file - icons

I’ve noticed a few irregularities the last days.

2020-03-26 13:00:15.908665  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_2101423648"
2020-03-26 13:00:15.830543  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_2772823636"
2020-03-24 21:35:02.033663  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_642016421"
2020-03-24 21:35:02.033663  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_1895600932"
2020-03-24 21:35:02.924288  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_2999446322"
2020-03-24 19:44:17.877403  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_2697358740"
2020-03-24 19:44:17.830526  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_2101350922"
2020-03-24 19:44:17.814901  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_338485944"
2020-03-24 19:44:17.439907  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_4151830379"
2020-03-24 19:44:17.408655  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_1565686533"
2020-03-24 19:44:16.283661  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_3281683593"
2020-03-24 19:44:16.127412  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_3109185658"
2020-03-22 19:44:18.143025  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_1812247054"
2020-03-22 19:44:18.033655  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_882832626"
2020-03-22 19:44:17.924275  INFO  Error opening file "files\\virtualserver_1\\internal\\icons/icon_3359886324"

You will probably say the server is missing some files due a move or such but no.
After a fair amount of years and database incontinence I created a new server on 3.10.x.

There is a few amount of uploaded icons which never got replaced or deleted yet.
Such icons named in the logfile may existed before the server got wiped.

The common clients connecting are still the same of course.

So the questions are:

Does a cached client icon cause an “info” in the server log if the icon doesn’t exist anymore?
(server instance log - log_0)

If so is this supposed to be like this?


Why do I ask?

I mean if the cached client icon is not found on the server but is still set as group, channel or server icon I do understand this error.

If a cached client icon is not found on the server and not set in any of these options why does my server receive an info about this?

If so I would assume the cached icons will be deleted by the TeamSpeak client and that’s it.

Guess this client who asks for the icons just connected to your server and disconnected from another server where the file transfer progress for these icons was no finished yet.

This is a bug in the ts3 client.

1 Like

merged by moderator

Hey i’ve a question. The Last topic for this was 2020 and now the question:

My Teamspeak Server spam the log_0 file with this stuff:

2022-12-21 19:25:34.931422|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_2053941699”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.010813|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_1638577534”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.015454|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_2315395611”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.023907|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_3833518794”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.071436|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_2218506223”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.071481|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_3721563306”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.164555|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_2822062636”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.164597|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_410504309”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.199229|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_1322830808”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.263892|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_1262925714”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.365494|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_1326419728”: Datei oder Verzeichnis nicht gefunden
2022-12-21 19:25:35.464637|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_2287681914”: Datei oder Verzeichnis nicht gefunden

and more of this … i’ve never used a icon with this ID and i will not use more icons than mine.

and of course the Server Spam too this:

2022-12-21 14:58:16.416303|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 14:58:18.001040|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 14:58:20.001031|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:08:16.495858|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:08:18.011756|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:08:20.001159|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:18:16.523635|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:18:18.001040|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:18:20.012174|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:28:16.543566|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:28:18.001057|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:28:20.001027|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:38:18.001017|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:38:20.001516|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:48:16.624123|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:48:18.012910|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:48:20.001037|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:58:16.738606|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:58:18.001016|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 15:58:20.011758|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:08:16.816981|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:08:18.001025|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:08:20.001026|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:18:16.952219|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:18:18.001033|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:18:20.001027|ERROR | | |TS3ANetwork::Send failed error: 111
2022-12-21 16:28:17.032534|ERROR | | |TS3ANetwork::Send failed error: 111

every 10 Minutes and no. The Accounting Server can connect to my server. accounting2 can connect too and all other things from teamspeak can connect to my server and no: the server crashes not! but this log spamming is a lil bit creepy

what should i do to fix this issue?

Best regards

Nothing has changed to these topics. Their answers in it still count.

First issue can be:

  • File or folder was deleted from hard drive.
  • User on system has no permissions to read the files and it’s sub folder.

Second issue can be:

  • Ports are not opened
  • Ports are forwarded to wrong IP
  • Firewall is blocking the process
  • hosts file was changed and sends our server to wrong IP
1 Like

Hey Chris, i hope you can help me so the follow things …

The First issue is fixed, i don’t know why but since 01.01.2023 all is fine, i’ve explicit allowed accounting.teamspeak.com and some other things for teamspeak in my iptables and now it works … sorry for that

But the second issue following.
2023-01-03 12:49:39.950776|INFO | | |Error opening file “files/virtualserver_1/internal/icons/icon_1059286315”: Datei oder Verzeichnis nicht gefunden

The Timestamp is: 2023-01-03 12:49:39

And in the _1 Log i’ve following found:
2023-01-03 12:49:39.281834|INFO |VirtualServerBase|1 |client connected ‘censored’(id:39402) using a myTeamSpeak ID from …

The Timestamp is exactly the same.

but of course before and after some other clients are connected and all is working fine and i got not this message that some icons fails only on this. In a other post means a teamspeak staff that is a issue from the teamspeak 3 that if a client disconnects from a server but the download from the icons are not done, so the download wants to be continued on amother server. Can you confirm and of course fix this?

Best regards.

Sure could be that issue or other clients still have the icons in cache and do not trigger a download. Did not think of that.
Can be tested by deleting client cache and then connect.

If nothing goes wrong in the logs then all is fine.

TS3 client only will get critical fixes if needed. This definitely none critical issue.
So our devs will concentrate on TS5.

3 Likes

Hey Chris,
can you remember your post from 2020?

you mean in 2020 it’s a TS3Client Bug and NO, some clients connect to my server the first time and this errormessages or whatever comes not

This is a Bug in Teamspeak since 2020 … since 2 Years is a bug here and you tell me that nobody will fix this bug since 2 Years? Sorry but I’m not sure what to think of that.

Yes and i told you that our devs are not working on TS3 as long there is nothing critical in it.

The bug is way older than 2020 and still non critical to move our devs from TS5 development to TS3.

1 Like
twitch instagram twitter facebook