Invalid key2 signature

Hello guys,

I was redirected from technical support to this forum. Our community purchased a 256 slot licence last night in order to host two Teamspeak Servers on our dedicated machines. The Teamspeak instances were installed without issue and they run fine. Clients can connect and communicate. The problem is that the licence is not being recognized with an according error being shown in the logs:

2021-12-16 19:53:05.722470|ERROR |Accounting | |invalid key2 signature

The error persists on both machines. I opened a ticket before and the Gentleman on the other end said that there was no problem with the licence. I have put the licence file into the root folder of the Server as instructed and a file is being generated upon start up which is called:

.ts3server_license_accepted

Any help is greatly appreciated.

Vuk

EDIT: Licence was broken, Technical Support and Sales Team resolved the issue by generating a new licence.

The license file did break during download. Use another mail client to download it.
Or the server you are try to use the license file is modifies. Make sure you downloaded the latest server from https://teamspeak.com/en/downloads/#server

3 Likes

Hello Chris,

I appreciate your response. Unfortunately I still get the same error. I downloaded from Edge, Chrome, Brave and Firefox browser and I still get the same error. I also downloaded the newest Server files from the link you provided. It still says that the key2 signature is invalid.

Vuk

Talked to our Sales department and yours is not the only one with that issue. But here on forum i can not do anything Sales related.

Please open a ticket for the Sales department. There you will get a new license.
https://support.teamspeak.com/hc/en-us/requests/new

Important:

Use the E-mail that the license is assigned to! Or else our Sales department has no proof of the ownership!

4 Likes

Thank you Chris, I have sent an according thicket from the E-Mail that the licence is assigned to.

Vuk

twitch instagram twitter facebook