Keybinding problem

Hi,
I use several controllers from virpil. But that doesn’t matter, because the problem remains even without the controller plugged in. As soon as I want to put a keybinding on a DX button, the recognition hangs and I have to use the mouse or keyboard to help stop the recognition. It seems that TS doesn’t catch the button release command.

I tried to set a key on the keyboard as a PTT. However, no button will work when Teamspeak is open as an active window. I have to activate another window so that the PTT works.

I’ve already tried compatibility mode and starting as an administrator and had no success. Have been using Teamspeak 3 for a long time without any problems.

New system - Windows 10 latest version, processor AMD x6950,
X570 chipset ASUS Board ROG Hero.

I dont have problems with other Software and the game controllers.

Can you help me?

Thanks
Alex

Probably Teamspeak does not support officially the controller for keybinds.

And the problem with the keyboard PTT?
Strange, that this behavior appears with all Joysticks that I have (Logitech Warthog, Sidewinder?) And also strange, that all Joysitck were functionally on my other system with TS3…so I don`t believe, that the Joysticks are the problem!

The problem persists on a naked install of Windows 10.

Eventually TS3 don’t support the new AMD systems…another person with same problems posted to have a Board with X570 Chipset…

twitch instagram twitter facebook