License invalid after migration to another Server

we just migrated our Teamspeak Server this weekend. It’s a small server with the free license. Unfortunately, we get an error which tells us that our license is invalid, even though we haven’t changed a thing. It’s a server with the free license and only the new instance is running.

Is there something we need to do? Last time it worked without any problems.

Any help would be appreciated.

Best regards

Update the server to latest version to ensure you got latest license with a valid date.

1 Like

Thanks Chris!
We are on 3.13.6, i forgot to mention that. So we should be on the latest version. The server is running Debian Bullseye stable.

We’ve found this in our logs:

2022-04-19 12:24:37.552091|INFO    |ServerMain    |   |Received signal SIGTERM, shutting down.
2022-04-19 12:24:37.552722|INFO    |VirtualServerBase|1  |stopped
INFO: User exists; skipping creation
Found a license agreement method; launching TeamSpeak
2022-04-19 12:24:38.187494|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)

Maybe that helps?

That log does not show much. The part of the license was cut off.

1 Like

Sorry about that.
This is should be the complete startup log.

Found a license agreement method; launching TeamSpeak
2022-04-19 11:37:17.295066|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2022-04-19 11:37:17.295303|INFO    |ServerLibPriv |   |SystemInformation: Linux 5.10.0-13-amd64 #1 SMP Debian 5.10.106-1 (2022-03-17) x86_64 Binary: 64bit
2022-04-19 11:37:17.295422|INFO    |ServerLibPriv |   |Using hardware aes
2022-04-19 11:37:17.295638|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2022-04-19 11:37:17.295693|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
2022-04-19 11:37:17.295843|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
2022-04-19 11:37:17.329069|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
2022-04-19 11:37:17.335841|INFO    |Accounting    |   |Licensing Information
2022-04-19 11:37:17.336019|INFO    |Accounting    |   |licensed to       : Anonymous
2022-04-19 11:37:17.336113|INFO    |Accounting    |   |type              : No License
2022-04-19 11:37:17.336213|INFO    |Accounting    |   |starting date     : Thu Oct  1 00:00:00 2020
2022-04-19 11:37:17.336265|INFO    |Accounting    |   |ending date       : Tue Nov  1 00:00:00 2022
2022-04-19 11:37:17.336343|INFO    |Accounting    |   |max virtualservers: 1
2022-04-19 11:37:17.336411|INFO    |Accounting    |   |max slots         : 32
2022-04-19 11:37:17.838209|INFO    |              |   |Puzzle precompute time: 484
2022-04-19 11:37:17.838788|INFO    |FileManager   |   |listening on 0.0.0.0:30033, [::]:30033
2022-04-19 11:37:17.843524|INFO    |Query         |   |Using a query thread pool size of 2
2022-04-19 11:37:17.894569|INFO    |VirtualServerBase|1  |listening on 0.0.0.0:9987, [::]:9987
2022-04-19 11:37:17.894974|INFO    |Query         |   |listening for query on 0.0.0.0:10011, [::]:10011
2022-04-19 11:37:17.895230|INFO    |Query         |   |listening for ssh query on 0.0.0.0:10022, [::]:10022
2022-04-19 11:37:17.895430|INFO    |Query         |   |listening for http query on 0.0.0.0:10080, [::]:10080
2022-04-19 11:37:17.895531|INFO    |CIDRManager   |   |updated query_ip_allowlist ips: 127.0.0.1/32,

Hmm, there is nothing wrong in the log.

No error or anything about the invalid license. The Warning is normal and tells you what the server does instead.

1 Like

Oh, ok.
But we still get the following warning when connecting to the server:
image

The server was flagged by our piracy department. Whoever owns or owned this machine did something against the license agreement.

To get of the list you need to contact our piracy department. There is nothing we can do here on forum.
https://support.teamspeak.com/hc/en-us/requests/new

2 Likes
twitch instagram twitter facebook