New teampeak server, centos system 9987UDP port does not work

Hello, I have some problems that cannot be solved during the process of setting up my teampeak with centos7. I hope to get help from netizens.

At present, I have added 9987 / UDP, 10011 / TCP, 30033 / TCP ports to the server, but there seems to be something wrong with port 9987 that prevents me from being able to connect to my server through the teamspeak client, and querying the 9987 port through the tool has been closed. .

However, I have added port 9987 through the command, and the returned information indicates that it was successfully opened.

Here are the logs:

2020-03-30 15:23:59.204949|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.12.0 (2020-03-18 11:53:17)
2020-03-30 15:23:59.205185|INFO |ServerLibPriv | |SystemInformation: Linux 3.10.0-1062.18.1.el7.x86_64 #1 SMP Tue Mar 17 23:49:17 UTC 2020 x86_64 Binary: 64bit
2020-03-30 15:23:59.205234|INFO |ServerLibPriv | |Using hardware aes
2020-03-30 15:23:59.206202|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-03-30 15:23:59.206245|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-03-30 15:23:59.206681|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-03-30 15:23:59.243104|INFO |SQL | |db_CreateTables() tables created
2020-03-30 15:23:59.342481|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2020-03-30 15:23:59.343789|INFO |Accounting | |Licensing Information
2020-03-30 15:23:59.343818|INFO |Accounting | |licensed to : Anonymous
2020-03-30 15:23:59.343833|INFO |Accounting | |type : No License
2020-03-30 15:23:59.343859|INFO |Accounting | |starting date : Sat Feb 1 00:00:00 2020
2020-03-30 15:23:59.343876|INFO |Accounting | |ending date : Mon Feb 1 00:00:00 2021
2020-03-30 15:23:59.343889|INFO |Accounting | |max virtualservers: 1
2020-03-30 15:23:59.343901|INFO |Accounting | |max slots : 32
2020-03-30 15:24:00.903608|INFO | | |Puzzle precompute time: 1508
2020-03-30 15:24:00.904523|INFO |FileManager | |listening on, [::]:30033
2020-03-30 15:24:00.905547|INFO |VirtualSvrMgr | |executing monthly interval
2020-03-30 15:24:00.905709|INFO |VirtualSvrMgr | |reset virtualserver traffic statistics
2020-03-30 15:24:00.992705|INFO |Query | |listening for query on, [::]:10011
2020-03-30 15:24:00.993113|INFO | | |creating QUERY_SSH_RSA_HOST_KEY file: ssh_host_rsa_key
2020-03-30 15:24:01.198062|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-03-30 15:24:06.735461|INFO |Query | |listening for ssh query on, [::]:10022
2020-03-30 15:24:06.735747|INFO |CIDRManager | |updated query_ip_whitelist ips:, ::1/128,

I am a newcomer and failed to install teamspeak under the windows system. According to the network tutorial using linux installation, the port status of 9987 is still closed.

How did you try to connect to the server? via the local or public IP?
(assuming the server is in the same network as the client)

Thank you for your reply. Accessed by public IP, this server is running wordpress blog and can be accessed normally through the Internet. :困惑:

Is the server by any means routed / NAT’d?
This would mean that you still have to forward the port to the server. If not make sure the firewall is configured properly for UDP 9987. If this doesn’t help try accessing the server through a tunneled connection to the server directly.
Also: You are located in China, right? Is the server also located in China? There have been some problems with the GFW.

Yes, I am from China. I don’t quite understand how to route. The server can currently access the webpage content running on the server through the Internet. Do I need to forward it to the server for port 9987? I tried to access using public IP and also cannot connect to the server.

Please check the webpage of the server provider whether you can open / forward the port there.

Thanks for your answer, Greetings from China: Good night