"Push To Talk" / "Hotkey" Feature Not Working

Question in the room: Why you have a second hotkey set (same key?!?) that mutes your mic?
The combination shown in picture 2 makes no sense that way.


I do not know. I am new to teamspeak 3, and the discord group I am a part of told me to make these settings. I am totally new to Teamspeak 3, and am trying to learn these things mostly by myself. I figure that I will make mistakes along the way until I fully learn…

Anyhow, I have removed the second hotkey setting, so now only one hot key setting exists - the Push-To-Talk default hot key. It still does not work…

And you are holding the key?

Asking because using hotkey definitely worked before when mute did work from the other hotkey.

1 Like

I press the “0” key of my number pad as I speak - in the test, it works: I can hear myself speak as I hold down “0”, and do not hear myself through my earpieces when I do not press down “0”. But once I connect to the server of my Discord group, it does not work. Others can ONLY hear me when I set it to continuous transmission…

Now I am getting constant notifications - cannot connect to myteamspeak account, and unable to decrypt data, please apply encryption back-up key. I do not understand what this is all about…

OK, I went into Tools>Options>MyTeamSpeak, and reset my Myteamspeak account settings (email and password), and that fixed the notification issues, although I do not know what that was all about: I had never gone into that MyTeamspeak tab under Options before…

Please check that you have an active hotkey profile set (in your case the Default one) in the bookmark.

One co worker made an oopsie and that’s why myTS service was working slowly or did not work.


One thing that bugs me: in the 3rd picture above, I red-circled the icon of the microphone with the “X” on it. That Icon says “Mute Microphone” - it would toggle on and off when I used to try the hotkey - that was when I also had the hotkey set up for toggling Microphone Mute. Now I have removed that hotkey, so it doesn’t activate that icon anymore.

But what bugs me is the icon to the immediate left of that icon - the microphone with the checkmark on it. That Icon says “Activate microphone”, but it is greyed out as if not turned on, and I have no idea how to turn it on or activate it. Since I am wanting to “turn on” my microphone when I push to talk, this is bugging me. I do not know if this makes any difference at all in my issue. It seems to imply to me that my microphone is not activated, which is the primary problem I am having with my push to talk feature…

You do not need to activate anything that is active already.
This is only used when you connect to 2 or more servers and where you want to talk you can activate the mic.


How do I check to determine that I have an active hotkey profile set? In the 1st and 3rd images above, it shows that I have “Num 0 (Default)” set as my hot key in the Capture tab. It also shows this in the Hotkeys tab as well. Is this not a hot key “profile”, or is that something different??

I made a summary for that topic


Here are my answers to your summary:

  1. I have a Windows 11 PC, with updated drivers. Please advise if this is not what you mean by “device”.

  2. I have provided an image capture of my Capture settings above. Please advise if this is not sufficient. Here is my Playback settings:

  3. I have tried the above settings as shown in the images. I have NOT set any bookmarks for any profiles.


  1. I have verified that drivers are updated.

  2. In both the Capture and Playback tabs, I have a “Default” options selected. There is a “V” down arrow to the right for Profile Details, that if I click on it, for both Capture I have “Microphone (2-CMedia Audio)”, and for Playback I have “Headphones (2-CMedia Audio)” as well as “Line (CMedia Audio)” as options. I have Windows 11, so for my input I have Headphones (2-CMedia Audio) and Line (CMedia Audio), and for output I have Microphone (2-CMedia Audio).

  3. By " select your device directly and not default under TS3 : Tools > Options > Playback or Capture", I assume you mean to just select the headphones/microphone (2-CMedia Audio) below the Default option in Profile Details? I did and nothing happened. Do I need to create a separate profile for that device in the Profile box to the left of the Profile Details? There is just the “Default” profile there.

  4. I currently have NO profile bookmarks established for either Capture or Playback devices. The bookmark page is empty.

  5. There are no profiles in my Bookmark page

  6. I have Windows 11. I do not know if the Windows 10-specific features are also specific for Windows 11. The settings for Windows 11 shows my microphone is set to allow for access to the microphone device, and desktop apps such as Discord and Teamspeak 3 are enabled for access to my microphone.

  7. My PC is a Windows Machine.

  8. As I have mentioned before, when I am just in my Teamspeak 3 client, I can test the push-to-talk feature in the Capture tab, and I get a strong audio feedback when I press the “0” hotkey, and silence when I do not press the hotkey. When I connect to the Discord server, the push-to-talk test feature suddenly does not work, and push-to-talk does not work. But when I select continuous transmission, that does work. Others on the server can hear me, and I can hear them.

  9. By “slider in your Capture profile”, you mean the background noise slider, that is set to 0 background noise.

  10. My channel is not moderated - often we have as many as 30+ in the channel, and they all are allowed to talk. I have no issues talking under continuous transmission. As for having enough power to speak, when I am in continuous transmission mode, no one has any issues hearing me, and in fact my “hot-miccing” is a bit loud, which is why I want to use push-to-talk mode.

  11. The channel is not in silence mode.

  12. I have not had any issues with not hearing others talk to me - it is when I try to talk to them in push-to-talk mode, that is a problem.

  13. The volume slider in Playback tab is set at 50% volume - I do not think I ever adjusted this, so it should be at default setting.

  14. The issue is not where I cannot hear others, it is where others cannot hear me when I use push-to-talk mode. I can hear others just fine.

  15. The Windows volume mixer is at 50%. I adjust this often watching videos on Youtube. That is not the issue - I can hear others fine.

  16. My headphones have a manual mute switch on the cable, but it is in “green” setting, meaning that it not muted at the moment.

Playback/hearing issues are not related for your problem. but thank you for that detailed reply.

  • At lest the hotkey profile must be set or else no hotkey profile is active.

Sure there also should be a capture and playback profile or else you will not be able to hear or talk.


I do not understand why there is no established tutorial/how to for new users so they can set up their Teamspeak 3 properly. This is basic software, regardless of devices or channels. The devices are also vastly similar in design and function: they are used to communicate with others over the internet, with audio. The settings would therefore be basic and general for most all devices, and therefore instructions on how to set up the teamspeak 3 would also be basic and general.

So here goes some more:

Does it matter what the bookmark name is? Or identity or nickname? What is the Default Channel Password - where do I get that? Thanks for all your help thus far.

Here is how I set mine up:

#off topic

No, no and no.
It’s just names you can give it.

Server nickname or Address is important. Else you cannot connect to a server. That’s btw the only thing needed to start with.

Back to topic of this thread:

I’m still sure your hotkey must work because it in test mode and the other to mute also worked fine. I do not see any reason why this works but another doesn’t (as long PTT is still set in Default capture).

When you only used the connect dialog to connect to a server then there also make sure Default was selected in your profiles.


Thank you for your help.

Does my bookmarked data in the image I provided look correct? By “Server Nickname or Address”, would this be the URL address of the Discord channel (ts.tsbgamers.org)?

When you say “when you only used the connect dialog to connect to a server then there also make sure Default was selected in your profiles”, do you mean there is a way to check my profiles AS I AM CONNECTING TO A SERVER? Once connected, my profiles in Capture, Hotkeys, and Bookmarks look EXACTLY the same as they do before I connected. I currently only have ONE server that I’ve connected to EVER, and only have the ONE profile set up in my Capture, Hotkey, and Bookmark tabs.

Before i answer your questions:

I’m still sure your key just should work because you only have Default profiles and never seen to changed anything here.

What you could try is to activate and Apply and then deactivate Apply this setting.

Now for your questions:

Yes. would’ve mentioned mistakes

Yes that’s a valid address.

I mean this dialog

Did not mean it but this is also possible to check and change.
Here you need to click on an empty space on top (next To Help as an example and activate Server Tabs)
Now with right click on that server tab you can see and change your profiles.


Here is what the profiles are when I connect:

I do not have a server password - they never gave me one…

Also, I turned on the “Add Voice Activity Detection”, tested it on the tsbgamers server, then turned it back off and also tested it, and it didn’t change anything…

Further, I have noted this, where I marked it:

That icon option says “Activate Microphone” - it is always greyed out, to indicate it is never activated or turned on. I have tried to activate it, but have been unable. Could this have something to do with my issue??

Ok? So server has no password set or you do not any to connect.

That’s something you wrote before. see below

Back to topic

So you using setting did also not help. I am out of ideas then.

Hotkey to mute works but same key for PTT doesn’t. I don’t see where in the world that’s possible.
The only idea i have is that a plugin could prevent this. But here I need a client log to see what plugins you have installed.

Are you really sure that the microphone was muted by the other hotkey you deleted?
Have you tried to set any other hotkey (or second PTT hotkey) or tried another key on your keyboard or on your mouse?


The tsbgamers server I connect to does not have a password. That is to say, they never gave me a password to use, and I can connect to their channels fine and talk with them fine, as long as I use continuous transmission.

I have tried other hotkeys to use, but there is a problem - the game I play with this group has a LOT of key binds for functions in-game, and most all of them are in use by the game settings, so I can’t use many keys for PTT. I have purchased a gaming mouse that will have programmable keys, and will try to bind a key there for PTT in the future, but it will be another week or so before it arrives.

I do wonder if I were to set a custom profile separate from Default, if that may work? Also, in Capture, the “Capture Device” dialog box that has “Default” in it, it has a little down arrow to the far right. WHen I clock on that arrow, it shows my headphones listed under Default (Microphone (2-CMedia Audio). Shouldn’t that be the device that is listed, since it is my microphone?

Do not see why Voice Activation is not an option here. If continuous works Voice Activation also will work.
So at least you will not send all the time and only when you speak.

And the result was what?

Don’t think so, but you are free to try it out.

Something else came into my mind. Can you try to change this setting? Maybe it helps.

off topic

Default in Device list is the “Default Communication Device” set in Windows and when you change it there then you do not need to change it in the client.


Changing the option in Hotkeys tab to “Keyboard & Mouse Only” did nothing, unfortunately. This thing has me totally baffled…

The other hotkeys I have used, all failed to work in the PTT function. I ultimately chose the numberpad “0” for my hotkey, because it was one of the few keys left that the game I play doesn’t already horde for hotkeys in-game. Beyond the “0”, I’m left with trying key combinations, like Right Ctrl+ “0”, or something like that…