"Push To Talk" / "Hotkey" Feature Not Working

Changing the option in Hotkeys tab to “Keyboard & Mouse Only” did nothing, unfortunately. This thing has me totally baffled…

The other hotkeys I have used, all failed to work in the PTT function. I ultimately chose the numberpad “0” for my hotkey, because it was one of the few keys left that the game I play doesn’t already horde for hotkeys in-game. Beyond the “0”, I’m left with trying key combinations, like Right Ctrl+ “0”, or something like that…

And when you set a hotkey that is not a PTT hotkey???

I still want to find out if hotkeys work at all because i stated more than once that it makes no sense that only PTT does not work while Mute hotkey as an example does work.


I have an update to give:

I was advised to uninstall Teamspeak 3 and re-install, which I did. I was also advised to set my Capture to Voice Activity Detection, and that worked! So the mic only picks up my voice when I talk, and does not hot-mic when I do not. So in that setting, it works in the teamspeak group I am in. As long as that works for me, I will use that as my quasi push to talk function.

I still do not understand why PTT wouldn’t work, but this is a satisfactory work-around for me. Thank you TS.ChrisR for all your help in getting my TS 3 working. Cheers!

I would be happy to try setting a hotkey for any other Teamspeak 3 function, to test if hotkey settings work - all the hotkeys I’ve tried setting, were set only for the PTT function…

moved by moderator.

Hi, i got a problem with teamspeak that when i apply a hotkey for “toggle mute” it works only when im not connected to any server, once i join any server i cannot mute myself with that hotkey and it really ruins the experience
Does anyone know a solution for this?

Check your bookmark that a hotkey profile is set at all.


It works now… its a really weird thing to but in the “connect” menu and i have no idea how i unchecked it…