Push to talk not working when im in a ts server

When I’m not in a server my push to talk mic works but whenever I join a server and use push to talk it won’t work. Please help me with this because I cant use TeamSpeak anymore since I’m only in servers where I need to use push to talk. I’ve tried looking in other forums but it just says make sure the playback and capture and hotkey is correct and what I know mine are correct but it still won’t work

What for a key have you binded?

Ive tried many keys and none works in servers. I’m currently trying to make it mouse button 5

Check your Hotkey Profile

Another possible cause of the issue can be your hotkey profile. If the wrong hotkey profile is selected in the settings, your microphone will not activate and hence prevent you from communicating with others. Therefore, you will have to make sure that the correct hotkey profile is selected if you have created one. Otherwise, you will have to make sure that the correct hotkey is assigned to the push to talk option. Do the following to check your hotkey profile:

  1. To check your hotkey profile, click on the Self option in the menu bar of Teamspeak.
  2. After that, move your cursor to the Hotkey Profile option and make sure that the correct profile is marked.
  3. Alternatively, you can go to the Tools option and then select Options from the drop-down menu.
  4. Afterwards, switch to the Hotkeys tab and make sure that the correct profile is selected.


works now. Thanks!

1 Like

You are welcome. :slight_smile:

If you have any other Questions, feel free to ask here. :slight_smile:

i have made sure that the correct hotkey is there and it still doesnt work

1 Like

Without more information I can just give some guesses =)
First, make sure the correct hotkey profile is selected too, as described above.

I experience my hotkeys (under Windows 10) not working if either TeamSpeak or my game was launched as administrator, while the other was not. When both are launched in the same configuration, hotkeys worked fine.

Another bit I can throw in is, that as far as I know, if u use Mac OS, you need to change system settings in order for TeamSpeak to be allowed to always watch for all keyboard inputs in order to notice hotkeys.

Push to talk will not work but continuous transmission does, i cannot speak when i hold down my hot key and have tried everything.

Try these steps:

1 Like

My push to talk is not working. I feel I have tried everything I have had to do to fix it, but it still will not work. I have had friends of mine also try and help me fix it. We found out it wasn’t my mic or anything with my audio devices, and that it is push to talk. I have tried unbinding it and using new keybinds, and it won’t even let me do a mic test. Voice activation works on the other hand, but that doesn’t cut it for what I use Teamspeak for.

1 Like

I found out the solution; due to the fact, the amount of ignorance that occurs on the forums, and the official TS3 website. The simplified, dumb down, solution would not be going to your Tools > Options > Capture or Hot Keys. If you’ve already skimmed through those directories, try attempting this:

I.) Head over to the tab, “Self”.

II.) Hover or click the three following and assure you have these marked down:

  • Capture Profile,
  • Playback Profile,
  • Hotkey Profile.

III.) Select the profile that you’re currently trying to enable. Since my client is a fresh install, the option provided is “Default”.

This is what my client looks like (Ignore the icons and theme, that is cosmetics.):
Note that this will all be under the tab, “Tools” > “Options” (At the very bottom):

Comment image

Here is the Hotkeys Section:

Here is the Playback Section:

If you need additional help and or assistance, my discord is “obradley” and my personal discord community that I’m most active on and most attentive within is: DaytonaRP | 5PD | QBC |

I hope this helped, also here are additional photos that shows my issue corrected:

Originally this was not checked off, although in my Tools tab it was Default and “checked” off in there.

The last picture does check while not connected. That’s not a check because the default profiles will always be selected as long no connection was made.

You must check while you are connected to the server.
You can select it then when no hotkey profile is selected.

After that you go into your bookmark and also set it there. Else it won’t be selected next time.

That’s actually funny to post this in a place where people got helped with. :-1:


I was connected to the TS server at the time, I just disconnected so no personal information was showing. Although default is the only option I have on the TS3 client, the Self category operates on its own. Therefore whatever changes you make in the Tools > Options section does not apply. I was clearing it up for others who are still having the same issue, due to the fact, others can not explain in such a fashion for the general population of users to understand.

The bookmark option was never explained, and even initially joining a server, the default option was never checked. Nobody explained the Self tab, and to clarify and make sure that was also looked over. Everybody kept assuming, “Oh, it’s only in tools and options, that’s the only issue you’re having.”

Rikku did explain the Tools > Options and the self part in Points 1 - 4

Who is Everybody? Don’t see that question or assumptions here and not in the the old forum.

That’s important to be connected. The bookmark or quick connect settings do apply which profiles are active.
So with 2 connections you could have different profiles selected or no profiles selected at all on one server while the other uses profiles.

If anyone in here had replied in any way that the hotkey still did not work or resets each time a connection was, then further informations would be given. But so far Rikku’s reply was on point for current help requests.


moved by moderator

I need help getting My push to talk to work in Teamspeak 3 client. I have win 11 home and while I am in team speak I push the hot key and the blue circle doesn’t show that I am talking and no buddy can hear Me. When I go into the test input or
Output everything works but when I go into the channel nothing works? I can hear them but they can’t hear Me. I have tried three different head phones and neither of the mic doesn’t work. I’m not sure how to setup permissions for the mic to work?

Please follow the Guide that was posted above.

I have bound the shift key

The key alone does not give much details and wasn’t in question.

Please read the given text from Rikku and tell us the result(s).