Server Query Timeouts After License Expired

This last weekend, my Activation licensed expired after 1 year.
No reminder email, forcefully shutdown my server.
Once, I renewed license and restarted my TS Server.
None of my Server Query apps work anymore. Instantly Timeout.
I can remote into SQ with telnet just fine and send commands, but it takes about 5 minutes
for it to return the results of the help command.

There are zero errors or warnings in the server logs.

serverinstance_serverquery_flood_commands=150
serverinstance_serverquery_flood_time=3
serverinstance_serverquery_ban_time=0

I’ve tried cranking these values up really high to no solution.
The server ran fine for 700 days until this happened.
All remote application IP address have been whitelisted for same amount of days.

About once every 30 minutes can an app get ONE command through.

I have upgraded to the latest server version as well.
I am absolutely stumped on this one.

Server version was 3.7.1
Even so, the serverquery issues happened after the activation license forced my server to shutdown.
So they we working with 3.7.1, then not working after it was shutdown and restarted with the same version.

I should also note, all the commands I’m passing still work, just at an extremely slow pace.

Thats an option? How do i enable that?

Thats cool to know.
Tried it with a tail follow of the logs. no query errors or flood errors…

It worked for about 5 minutes. now its timing out again.

are you sure that your query plugins send a valid keepalive? because a \n is not considered as valid keepalive anymore, there needs to be atleast something like " \n" to be valid
atleast it feels like it could come from there because by default 5 minutes is the time the query needs to send a command to not get disconnected from the teamspeak server

2020-04-24 00:33:19.664971|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.12.1 (2020-03-27 10:38:47)
2020-04-24 00:33:19.665081|INFO |ServerLibPriv | |SystemInformation: Linux 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 Binary: 64bit
2020-04-24 00:33:19.665106|INFO |ServerLibPriv | |Using hardware aes
2020-04-24 00:33:19.711776|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2020-04-24 00:33:19.711856|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2020-04-24 00:33:19.799408|INFO |DatabaseQuery | |checking database integrity (may take a while)
2020-04-24 00:33:19.941716|INFO |Accounting | |Licensing Information
2020-04-24 00:33:19.941813|INFO |Accounting | |licensed to : xxx
2020-04-24 00:33:19.941827|INFO |Accounting | |type : Activation License
2020-04-24 00:33:19.941846|INFO |Accounting | |starting date : Sat Apr 18 00:00:00 2020
2020-04-24 00:33:19.941857|INFO |Accounting | |ending date : Sun Apr 18 00:00:00 2021
2020-04-24 00:33:19.941866|INFO |Accounting | |max virtualservers: 2
2020-04-24 00:33:19.941875|INFO |Accounting | |max slots : 256
2020-04-24 00:33:21.650101|INFO | | |Puzzle precompute time: 1369
2020-04-24 00:33:21.650508|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2020-04-24 00:33:21.839328|INFO | | |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-04-24 00:33:22.032151|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2020-04-24 00:33:22.032706|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2020-04-24 00:33:22.032765|INFO |Query | |listening for http query on 0.0.0.0:10080, [::]:10080
2020-04-24 00:33:22.032822|INFO |CIDRManager | |updated query_ip_whitelist ips: 96.4x.xxx.xxx/32, 127.0.0.1/32, ::1/128

It just logs in to SQ issues X commands then disconnected immediately by design. It fires off a few commands and then times out before it can do the rest in matter of milliseconds.

yeah that could be antiflood,
the query will respond with an error with id 524 if the query then does not respect that and still sends commands the teamspeak server will ban that ip for 5 minutes

even if said server is whitelisted? Also, i just now noticed when i did a telnet into it. i typed servergrouplist command and its hanging and not returning anything.

hmm no if the server is whitelisted it should be okay
return may hang when you accidentaly press CTRL+C (happens to me all the time)

do you mind sending details of the query bot you are using?

it hangs on both “servergrouplist” and “help”

I can execute all other commands flawlessly except for those 2

the application im using is in this github

Workes for 15 minutes today. But now when the command “servergroupslist” is issued it doesnt return a result and just hangs.

It’s a 256 slot , 2 virtual. Each servers got maybe 15-20 servergroups. But in particularly calling for server 2 servergrouplist. And yes its 100% everytime hanging on the servergrouplist and help command never returning a result.

from localhost serverquery telnet connection, i can spam said commands hundred of times without failure.

telneting from my home machine with my ISP Address whitelisted. It hangs endlessly. Lets me execute the command once every 30 minutes.

It does indeed show it reading the whitelist, and it shows my ip addresses. and it does live update when i add a new one into the list

2020-04-24 23:56:04.164291|INFO    |              |   |myTeamSpeak identifier revocation list was downloaded successfully - all related features are activated
2020-04-24 23:56:04.218637|INFO    |Query         |   |listening for query on 0.0.0.0:10011, [::]:10011
2020-04-24 23:56:04.218844|INFO    |Query         |   |listening for ssh query on 0.0.0.0:10022, [::]:10022
2020-04-24 23:56:04.218896|INFO    |Query         |   |listening for http query on 0.0.0.0:10080, [::]:10080
2020-04-24 23:56:04.218950|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 35.192.xxx.xxx/32, 96.41.xxx.xxx/32, 127.0.0.1/32, ::1/128,

perhaps I’ve found more of a discovery.
since this system is running 2 virtual server for TS
i did everything i’m trying on sgid=1 and it works
sgid=2 doesnot allow me to enter the commands i want.

editL i lied, it just stopped allowing me to enter those commands.
This is starting to seem like a waste of 200 dollars.
online for 700 days and all of a sudden, the license server
forces my server offline because i forgot to renew it.
renew it and everything is destroyed.

a fresh install of TS server allows me to spam commands unlimitedly while in the whitelist

I’m a bit confused - does ‘help’ now work, but anything involving the 2nd server doesn’t?

1 Like

the help command only works if issued from localhost on the teamspeak server
it does not work from a remote telnet connection.
Once every 30 minutes to an hour i can issue the servergrouplist of serverinfo commands one time
from the remote connection.

the remote ip is whitelisted and has been for 700 days. all configurations have remained untouched
in that entire time. but the moment the license server shut me down. i can no longer remoteley administrate my server.

in the server logs. i can see in realtime the commands being issued. but the query console returns zero results.