Server Started Shutting Down And Starting Again

Hi All,

I just noticed that my TS Server hosted at home was disconnecting and connecting randomly.

I cleared the logs and sat and waited for it to do it again. About 10mins later it did again. This is the log 0

2022-08-03 15:25:56.683952|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.13.6 (2021-06-09 10:22:37)
2022-08-03 15:25:56.684217|INFO    |ServerLibPriv |   |SystemInformation: Linux 5.4.0-122-generic #138-Ubuntu SMP Wed Jun 22 15:00:31 UTC 2022 x86_64 Binary: 64bit
2022-08-03 15:25:56.684245|INFO    |ServerLibPriv |   |Using hardware aes
2022-08-03 15:25:56.684786|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 3, (c)TeamSpeak Systems GmbH
2022-08-03 15:25:56.684817|INFO    |DatabaseQuery |   |dbPlugin version: 3.11.1
2022-08-03 15:25:56.684969|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
2022-08-03 15:25:56.715792|WARNING |Accounting    |   |Unable to open licensekey.dat, falling back to limited functionality
2022-08-03 15:25:56.716147|INFO    |Accounting    |   |Licensing Information
2022-08-03 15:25:56.716173|INFO    |Accounting    |   |licensed to       : Anonymous
2022-08-03 15:25:56.716185|INFO    |Accounting    |   |type              : No License
2022-08-03 15:25:56.716204|INFO    |Accounting    |   |starting date     : Thu Oct  1 00:00:00 2020
2022-08-03 15:25:56.716225|INFO    |Accounting    |   |ending date       : Tue Nov  1 00:00:00 2022
2022-08-03 15:25:56.716236|INFO    |Accounting    |   |max virtualservers: 1
2022-08-03 15:25:56.716245|INFO    |Accounting    |   |max slots         : 32
2022-08-03 15:25:57.370730|INFO    |              |   |Puzzle precompute time: 639
2022-08-03 15:25:57.371264|INFO    |FileManager   |   |listening on 0.0.0.0:30033, [::]:30033
2022-08-03 15:25:57.385335|INFO    |Query         |   |Using a query thread pool size of 2
2022-08-03 15:25:57.422922|INFO    |Query         |   |listening for query on 0.0.0.0:10011, [::]:10011
2022-08-03 15:25:57.423118|INFO    |Query         |   |listening for ssh query on 0.0.0.0:10022, [::]:10022
2022-08-03 15:25:57.423185|INFO    |Query         |   |listening for http query on 0.0.0.0:10080, [::]:10080
2022-08-03 15:25:57.423243|INFO    |CIDRManager   |   |updated query_ip_allowlist ips: 127.0.0.1/32, ::1/128, 

And log 1 with not much on it.

2022-08-03 15:25:57.422710|INFO    |VirtualServerBase|1  |listening on 0.0.0.0:9987, [::]:9987

Does anybody see anything that might be causing this? Thx in advance. Appreciated.

You wrote shutdown but There is no shutdown in the logs :person_shrugging:?
Update your server to latest version and try again.

You connect with localhost or your LAN IP and guests with your external IP/Adress.
Check ping of your client and from those who timeout.

1 Like

Hi,

Yeah sorry. Not shutdown, but I disconnect for around 30 secs or so and then connect again. I have updated to the latest version and tried again but get same results.

This means that the server wasn’t offline? If there is nothing else in the server log, your client log would be helpful. Is it only happening to you or are other users also getting affected by the timeouts?

I have not used it much and no one really does so much anymore lol…However when I am using TS5 nothing happens. No logs and no disconnecting.

I am connecting on Windows PC and server is setup on Linux in my LAN.

I have dynamic IP address that resolves to a domain with NOIP. All works fine with that and the gaming servers.

Is there a way that I can connect to my TS server with domain name. i.e. Not with local 192.186.X…X address? One thing I did notice is ts3index.com #292149 keeps connecting to Lobby and disconnecting straight away. This happens every ten minutes or so?

Maybe i just keep using TS5 now and forget about Client 3

Ok i lied haha…Keeps losing connection in there too…I thought maybe it is something to do with how I am connecting.

twitch instagram twitter facebook