[solved] TeamSpeak Client does not start on Linux

I’m using an NVIDIA GPU + AMD CPU and I’ve got a similar result on Kubuntu 20.04 with Kernel 5.4.0. It seems to be a problem in the fresh build. Older Builds that were updated seems to work.

Maybe someone can send a version that works.

So, from what I can read, we have following (sorry just in case for ”@-ing” everybody):

EDITS, EDITS, EDITS EVERYBODY

2x AMD CPU with integrated graphics - not working (@Willie30F and @Kaeo_Szenoen)
2x Unknown CPU with nVidia GPU - working (@Gamer92000, @walamana - fixed)
1x AMD CPU with nVidia GPU - not working (@Timo-Timeout - not really sure given the way of writing post)
1x AMD CPU with nVidia GPU - working (@Mixus.one - fixed)
2x Intel CPU with iGPU - working (@Dr_Pepps, @IgnoredAmbience - fixed)
2x Intel CPU with nVidia GPU - not working (@Adaoh, @Deliru)
1x AMD CPU with AMD GPU - working (that’s me, can’t ”@” more than 10 people, I’m 11th right now)

What if, just if, there is a problem with Chromium on CPUs with integrated GPU? But problem with that is there is one example of iGPU working, so that theory falls apart.

Uhhh, it’s really annoying seeing you can’t fully enjoy TS, just because you like penguins…

1 Like

Sorry for double post, but ”@-ing” more than 10 people gives an error.

So, to finalize previous post…

@TS.ChrisR, is anybody from Staff reading this thread? Simple answer will probably be enough for now, I think.

EDIT: I see you liked it, so someone is alive here after all. That’s a relief.

2 Likes

If it can help, my issue was with an i5 6500 with 2x4GB of [email protected] Normally it has an iGPU, but installing TS5 worked perfectly fine with my 9400F (no integrated GPU) and 2x8ram @3200mhz

At least it’s not exclusively related to iGPUs being present, as I can’t run it with no iGPU in my processor whatsoever.

AMD Ryzen 3700X here (without iGPU) with an nVidia GTX1080 discrete GPU.
Kernel: 5.8.14.zen1-1, lts stock kernel (5.4.83-1) isn’t working either.
nVidia Drivers: 455.45.01-1 (via dkms)

To confirm, not working for me.
Fails with all the following flags:

  • ./TeamSpeak
  • ./TeamSpeak --no-sandbox
  • ./TeamSpeak --no-sandbox --use-gl=swiftshader
  • MESA_GLSL_CACHE_DISABLE=true ./TeamSpeak
  • MESA_GLSL_CACHE_DISABLE=true ./TeamSpeak --no-sandbox --use-gl=swiftshader

ldd output

The GTX 1080 (and 1080 TI) I think are the ones having trouble in general. That’s on nvidia though.
For this it should be enough to start TeamSpeak using --no-sandbox.

If the error persists it might be related to this mysterious problem discussed here.
For those that it’s not working, have you tried launching chromium itself?
If this does not work either this discussion should maybe discussed on the chromium forum.

Chromium itself (at least version 87.0.4280.88) works even when TeamSpeak does not.

1 Like

Yeah I’ve testet it too :D.
My specs are:

Intel i7 6850k CPU with
32GB DDR4-2400 CL16 RAM

In the meantime I upgraded my GPU from GTX1080 -> RTX3070

Same result as before:

So far Teamspeak is the only application refusing to work at all. Anything else works fine for at least two years with that GPU. This includes (heavy) gaming, chromium/google chrome (or anything else chromium based), video playback, electron apps and anything else I can think of that makes use of GPUs.

Using any of the mentioned ways of starting teamspeak in this thread do not work for me.
This is likely a general incompatibility of Teamspeak with nvidia drivers, but certainly not exclusive to the GTX1080 (which by all means are solid card, even on linux.).

Also as already mentioned, I tried all available driver versions, old and new. On 3 different machines with 3 diffrent nvidia GPUs (540m, GTX770, GTX1080). On every single one Teamspeak is immediately crashing on start.

This is really weird. It is known that a GTX 1080 might cause problems (I have to agree though that it is a really solid card).
But I really had to go out of my way to find a combination that is not working.
All the distros / drivers I normally use worked out of the box for me.

Try with the following before running the client.

mkdir -p $HOME/.config/TeamSpeak/Default
9 Likes

This has fixed my problem. Thanks!

Wow, THANK YOU! This fixed it for me too …
How did you manage to stumble across this? :laughing:

1 Like

It’s nice hearing that problem is going away.

But there’s still one problem…

Why isn’t this folder created automatically and need all of this to work? It shouldn’t be like that after all.

2 Likes

This really worked. Thanks a lot… Amazing what a missing folder can do…
The Teamspeak Team probably just has to do a very little fix. I hope they fix it asap (but enjoy your christmas time :slight_smile: ).

Getting a clean install of PopOS and trying to start ts5 it will crash instantly.
After some googling I found that this is the solution.
Would be great if it could get fixed in some way.

mkdir -p $HOME/.config/TeamSpeak/Default

Thank you all for the reports and the solution!
The next client Beta38 will add a fix.

6 Likes

Then just make sure to update the installer/download on the beta page to that version.

Thanks, this works for me too. I hope they’ll update the download page soon.

Within next 24 hours :smiley:

7 Likes
twitch instagram twitter facebook