Teamspeak 3 on IOS 16 for iphones does not support air pods anymore

Since IOS 16 for iphones it is not possible to use your air pods with teamspeak anymore.
This is true for me and 2 friends. All of them are using Iphone 13 pro and Air Pods 3rd generation.
All you can hear is way to heavy deepened voices - you are unable to understand anything.
We tryed deactivating 3D sound and other new features to IOS 16 but still no sign of better sound quality.
Definitely something the devs should be looking to fix, as their is no real use of the app anymore for mobile communication.
Please comment if you got a similar experience on other Apple devices.


1 Like

I tested this with an iPhone X and iPhone 11 Pro Max running iOS 16, along with AirPods 2nd Generation, and the capture and playback worked fine. We also conducted tests with an iPhone 12 and AirPods 2 Pro, and they functioned as expected as well. Therefore, I wouldn’t say that it’s impossible to use AirPods with iOS 16 anymore in general.
Maybe this only happens with 3rd generation airpods but i don’t think so because of the fact that they are using the same sound h1 sound chips.

Can you maybe gather some more details to reproduce this bug?


I use an iPhone 14 Pro Max with AirPods Pro on iOS 17 Beta 3 and have no problems. Only when I connect the Airpods after I have already started Teamspeak, the incoming as well as outgoing sound is distorted and is output similarly to “robots”. But restarting the Teamspeak app has always been a quick fix so far.

The issue still exists. If you start the TS app and than connect your airpods - the sound is distorded.
Same is true if you are in teamspeak and you get a call on your iphone. When you finish your call the teamspeak app is distorted and you have to restart. Same for alot of apps that play sound.
This is not just me. Like I said - 2 friend of mine have the exact same problem.
It’s easy to reproduce. A year ago this was not an issue - it only came after I updated to iOS 16.
Since than me and my friends have this.

I can confirm it the way you have described it now. Your original post sounded more like it wouldn’t work at all.


Thanks for confirming.
But I can not agree that restarting an app is a quick fix.
In regard to competition it is a fatal error and the main reason why I don’t use the mobile app anymore.
Switching between Macbook and phone with your airpods is also not possible without restarting the app.

I didn’t mean that it is a permanent solution. Only that you can quickly get it working again. I only use the app in rare cases, so it’s not so annoying when I have to restart it. Occasionally when I’m not near my PC. But if you use it really often, a bug like that can definitely be a dealbreaker.

Thanks, @T03IAS and @Gronosh for the details and further Information. We’ll be concluding more tests, especially when getting called, accepting it, and then returning back to the TeamSpeak App, as well as connecting the AirPods after joining a server.

If you’re able to gather any more information or recordings with audio examples, please don’t hesitate to leave them in this thread.



Thank you for providing these specific details, as they now help recreate the issue.


My friend got AirPods 3. gen and I can confirm, that there issues with AirPods 3. gen on iOS 16 (iPhone 13 Pro). Mic doesn’t work, start working after a few reconnects, but normally works with phone calls, viber etc. Its confirmed TeamSpeak issue.

My friend with an Iphone 14 pro and Airpod Pro 2nd generation has the same problem.
It is with every Iphone and Airpod generation.

I think this is not a problem with Airpods only, but with Bluetooth headphones in general.
I have tested Airpods Pro, Sennheiser Momentum 3 and Sony WF-1000MX3.
All have the same problem.
I still have one or two Bluetooth headphones here.
Logitech Zone Vibe 125
Microsoft Modern Wireless Headset
Jabra Evolve2 65
I’ll test them when I get a chance if they behave the same way.

1 Like

What i could reproduce was the following:
1.) Distorted sound when connecting BT-Device after starting the client
2.) After getting a phone call

Are there still another cases for you to run into the distorted sound issue?


I tried some things but so far these are the only causes I could find.

There are two confirmed issues.

  1. [iOS only]: when u change bluetooth device, for example: if you go from car to AirPods, it causes robot voice. Same happens if u talk on TeamSpeak on AirPods or in car’s bluetooth, and then u disconnect bluetooth but u stay on teamspeak, voice becomes robot’s like.

  2. AirPods 3. gen doesnt work with TS3 iOS app, but it normally worked with AirPods pro and AirPods 1. gen (confirmed, same phone).

Also, when you take out the airpods from your ears and put them in the case while everything was functioning well - the sound of the phone gets distorted. So it seems to happen either way.
As soon as you change the sound/microphone devices while the app is in use. You get distortion.

Right now we are at a weird spot.
2 of 3 including me can’t use teamspeak with bluetooth devices at all.
This seems to be the case since we updated to IOS 17

A fix is in the Appstore. This will take up to 24 hours to show up on all devices.

1 Like

The update ist out


fixed with the new update!

So far it’s working great. Great work!