Teamspeak 3 on Os X El Capitan

Hi.
Is there a chance to work Ts3 on El Capitan because it doesn’t let me update the program…It requires a newer version :frowning:

We are not aware of that it does not work.
But you should be able to update your Mac OS anyways when your device is not older than 10 years.

3 Likes
twitch instagram twitter facebook