TeamSpeak Server 3.13.3 [Important Security Update]

$ docker pull teamspeak:3.13.3
3.13.3: Pulling from library/teamspeak
no matching manifest for linux/amd64 in the manifest list entries

I think that something is not working as it should

1 Like

docker pull teamspeak:latest and docker pull teamspeak:3.13.3 just work fine here.


My post was sent 3 hours ago, the fix has been applied 2 hours ago.

Sooo, problem solved, I’ll update my server when possible

1 Like

No. We do not want to advertise details about this issue.

But i can tell “Nobody could get permissions on your operation system or get access to it.”
If that worries you.

Yes. We also want to have such kind of Newsletter for releases.



I can understand the security reason behind that (people will abuse it to destroy servers), but in some way it needs to be published, hiding it won’t help in any way.
I hope that the decision is temporary and made to allow people to update their servers, otherwise will sound very bad to me.

At security fixes it would always be interesting which versions are affected. If you know this.

1 Like

It’s an issue about Privilege escalation, so you should consider it as it affects all the versions before the patched one.

1 Like

Telling people how to abuse bugs also helps nobody. It causes more problems that we try to avoid.

No we are not going into details for this.

Anyone is allowed to update anytime. Does not matter if we share more details or not!


Is there a way to find out if this has been exploited on my server?

1 Like

The chances are low that it happened on your server.

You could make a backup and watch if anything suspicious happens. But please don’t start to get paranoid about anything on your server :cowboy_hat_face:.
As said the chances are low.


We discussed that again and decided to give you all some details January 2021 (no fixed day).
We must give hosts enough chance to update their servers first. And some days aren’t enough for this.


Given your track record of broken server versions, I really do not trust you enough to be updating immediately.
And that is precisely why I would like to at least know what versions are affected, so I can make informed decision.


Then is your only option to update next month. Your decision at the end.


When exactly will you release more info about the exploit?


1 Like


I recently updated from 3.12.1 to 3.13.3 and sometimes my Teamspeak crashes with the following error:

terminating with uncaught exception of type boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::system::system_error >: remote_endpoint: Transport endpoint is not connected

I have never had such a problem before. Am I the only one? Do you have an idea of what can cause this issue?


1 Like

Are you shutting down or start virtual server often (no matter if you use -virtual or normal start command)?


No, I only shut down and start the virtual server when I need to update. I run it on a Linux machine.

Nice, teamspeak keeps its word, as always …


2 posts were split to a new topic: myTS ID doesn’t get banned