TeamSpeak server could not validate your myTeamSpeak ID, im the only one that gets this message

Everytime i connect to a TS server the message “The TeamSpeak server could not validate your myTeamSpeak ID. Some myTeamSpeak related services are not available.” pops up with the following pop up that “The icon for the server was not found.” and also other icons are not found. and this only began happending recently. I have looked at different posts on the forum but have not found an awnser to the problem.

I am not the server holder

And i am the only one on the server that has this problem.

I am using teamspeak 3 btw

Please take have a look at this Thread on 1st Post: The TeamSpeak server could not validate your myTeamSpeak ID

And can you post your TeamSpeak 3 Client log?

i dont have acces to that as i am not the holder of the server, but i am the only one that has this problem

I mean not the Server Log. You have access to the Client Log.

The Client Log is stored under: AppData\Roaming\TS3Client\logs

1 Like

You may get the message caused by a password reset and you can not change it till you enter your recovery key in the client or do a fallback in the client.

1 Like

ok, i did change my password, but i do not have the recovery key. And i have made a hole new user and reinstalled teamspeak after that, but the same thing happens after that

Then please do the following and do a fallback maybe you are lucky and its recovered. :slight_smile:

1 Like

Some success. I can now se my personal icons, but not the icons for the differnet servers

Your icons, which you see next to your nickname on all servers, are your myTeamSpeak badges. You can customise them via your myTeamSpeak account. The server icons have nothing to do with this.


That’s no issue on your side. That’s on server’s side.

The problem can be solved by moving the file folder to the new location of the server or by uploading the icons to the server again.

1 Like

What about avatars

The server owner has the possibility to allow avatars on his server,
so please contact the Server Owner

ok. thx for the help guys i will contact the owner with a better understanding of the problem.

The server shows the error message <21:04:02> Transfer "avatar" reports: (lost file transfer connection), which means that the required ports aren’t enabled.

The admin of the server needs to open the filetransfer port 30033 TCP.

Other useful ports for the TeamSpeak Server can be found at TeamSpeak Ports.


Note: This could actually also cause the issue of the icons. The port must also be enabled for this.

2 Likes
twitch instagram twitter facebook