TS3 Freezing after a few seconds (Asus Graphics Card)

I start TS like i do with opening the client, and after maybe 30 seconds, teamspeak complexly freezes up. I cant scroll through anything, cannot click anything, it just becomes a still painting. I can hear people in my TS channel, but they cant hear me. Cant even close it down, have to do it through task manager. And repeat, don’t have any actual log nor dump from it. Ive tried clearing my cache, reinstalling.

I do not want to go thru the pain of reinstalling windows 10 just to get teamspeak working, when it was working just fine some days ago, and nothing has changed on my system.

I have contacted the support but all help i got was that i should ask the community

‘‘We sadly can’t support a technical issue like this here, there are to many possibilities. We would ask you to post your issue in our forum’’


1 Like

My guess here is that you use ASUS graphics card and their Tweak/Overclock software is running.
That one causes freezes.

The only solution we have is that you uninstall that software.


I do have ASUS Tweak software, i’ll try and uninstall it! But just quick question, how come it could make TS3 freeze? Just wondering out of curiosity.

1 Like

And Teamspeak works now! Thanks for the help


So this resolved my problem as well… You don’t actually have to delete the ASUS Tweak software. I closed it out and restarted it once I had Teamspeak up and running and everything is working again. If you select the gear in the ASUS software you can also just stop it from starting up when windows starts! That way you can go back to it if you need to…

2 or so minutes form startup, teamspeak keeps freezing, and while I can join a server, after that time I can talk and hear, but I cant interact with anything and have to force shut ts when I want to stop using it. Have no idea what causes it, I have no plugins, have updated, used old versions (3.2.1), (3.3.2) and I’m currently using the newest version (3.5.3). Have tried all of those versions and reinstalling and I cant seem to solve this, started happening randomly about a month or two ago. I’d like to actually be able to USE ts3 again.

Hi ShadowGCPereira
Could that be the reason?


I’m gonna try that out. I am running that software. Sorry for posting about it again, but its just that I couldnt find anything about it.

Yup, everything is up and running. Thanks :slight_smile: Sorry again for posting a repeated topic.

2 posts were split to a new topic: My client is freezing