3.6.0 Changes audio settings (Mic Boost, Monitoring etc.) on Asus Sound Cards

Every time I start the Teamspeak client after the latest update it keeps turning off my mic boost in Windows sound properties of microphone device. What’s up with that? I have everything switched off in the Capture sub-menu.

Win 10, Asus Essence STX II, Teamspeak 3.6.0 64 bit

Make sure to setup your microphone correctly.

Haven’t had a problem for years before, I rolled back to previous version and everything went back to normal.
Why does this option need to be unchecked?

Good evening, this option prevents the Program to make changes to your microphone.

Best Regards

I have the same issue with version 3.6.0 64bit. I also have similar sound card with an asus xonar essence stx and windows 10. As soon as I load teamspeak it will uncheck the mic boost in windows and in the drivers. I have tried latest drivers and unchecking the options under exclusive mode. The only thing that works is reverting to the previous version of teamspeak. Then I have no problems. Let me know if you figure anything out.

doesn’t the card come with software? Xonar Essence program?
Try to uncheck the Microphone boost within the Software

I have tested it by having windows sound tab open where u can see the mic boost option on and also in the sound card program where it shows them both checked as mic boost being on. Once teamspeak is opened they become unchecked (which is off). This does not happen with previous versions of teamspeak.

The client itself doesn’t touch any setting and only reads values. But with the WebRTC update it may be that there something triggers this. We can’t reproduce this yet on our devices but need to evaluate more.

Is this also happening with a TS5 beta client?

You can use badge code multipass if you need it.

1 Like

I tried the beta client and it has the same issue as 3.6.0. Here is a video of what happens. https://youtu.be/6kBhiy8KChs

Dxdiag Maybe this will help.

We have a similar issue here on our PCs sporting the ASUS Xonar DX.

Hardware in use: 5900x, 32GB RAM, 6900XT and ASUS xonar DX Soundcard on both PCs.
Software Windows 10 newest Version, ASUS Xonar DX driver newest Version.

When you start the new Version 3.6.0 TS3 Client it changes the setting for “monitor Microphone” in advanced Mic Settings in Windows Sound Settings (Systemcontrol) to enabled. Resulting in hearing your own voice while talking.
We have to disable it every time we use TS3, also after closing your software the problem is still present.
Tried reinstalling Windows, messing with the driver, to no avail.
Until we have a solution for this we installed the previous TS Version again.

Please note: The boost setting is not affected.
Only the Setting for “hear yourself while speaking” in the user defined tab is set to enabled when your software is started.

The following screenshot shows the setting menu:

@TS.ChrisR Is it OK to add this to this thread, or should I open a new one?

moved by moderator

So I just got the same issue after updating to the latest version. It has to have something to do with the update because I used teamspeak without this issue before that, updated and the issue was there. Basically everytime I open teamspeak microphone monitoring in windows will be activated and I hear myself until I disable it

Edit: I also have the ASUS Xonar DX

We could reproduce that changes happen with a Sound Card from Asus.
But we still do not know why Xonar in combination with TeamSpeak is doing that.

1 Like

No, unchecking the exclusive mode in mic properties doesn’t solve the issue.

I don’t have time to install and uninstall things back and forth so I don’t know about the rest. I rolled back to previous version and everything is fine. Well, maybe besides the annoying update prompt on startup, it’s insane that you can’t switch that off.

I have a Xonar DGX using the 1.81a Uni Xonar drivers from UNi Xonar Drivers official page on Windows 10 22H2 (build 19045.3086)

The Monitoring and Microphone Boost options are disabled upon starting TeamSpeak 3.6.0 when the Front Panel option is disabled. When Front Panel is enabled and TeamSpeak is started, it enables both Monitoring and Microphone Boost. As I use the rear jack this is not ideal for me.

Exclusive Mode option makes no difference to the behaviour.

Asus Audio Center was tested both running/not running under the conditions above and the result is the same.

Is there anything else I can provide that will help troubleshoot the issue?

Hey there,

I have the same issue after updating to 3.6.0

I’m using a Xonar Essence STX I with the latest Driver ( at Windows 10 21H1 (19043.1526)

For me its unnecessary to turn off front panel etc. The internal soundchip is deactivated at Board Propertys.

When I close the xonar programm so its not running and start TS its the same issue.

What happened since the last update and when do you fix it?

For me its annoying now to use teamspeak so i switched to discord, there this things didnt happened.

Same problem here (monitoring of mic) with Asus Essence STX II, after installing 3.6.0. No such problems with last version. Disabling the front panel mic solved the problem in a test.

Any news or anyway we could help to solve the issue?

Today there were a new Version (3.6.1) available.

But installing these doesn’t solve the problem. After updating to 3.6.1 and restarting my System the issue is still there.

Only Workaround is to downgrade to 3.5

It’s still being worked on, see here:

(If this is even worked on at all)


Any news for this?
3.6.1 did not fix this issue.