Add Direct Sound for audio

There is a known problem with TS and sound interfaces for condenser microphones where you have a disturbed qualitiy with windows audio session and the quality is clear with Direct Audio. This setting option should be in the new TS aswell.
When doing that, it would be nice to fix the bug where you get a bigger input lag over time with Direct Audio setting.

1 Like

Direct Sound is a deprecated part of Windows and so we also do not longer use it or have plans to use it.

7 Likes

But someone really has to take care of that. TS3 microphone mode auto and Windows Audio Session both turn my voice into a robot when I use VoiceMod. The people at VoiceMod cannot change that, because the voice is transmitted correctly. Teamspeak seems to get something wrong with that. Direct Sound is the only mode that fixes it. The disadvantage is that there is an extreme delay after a while. There must be a way to receive the audio signal correctly. As nice as the new Teamspeak is, but I won’t be able to use it like that

I have the same problem with the beta TS5 and TS3 stable where I have to use the direct sound mode to avoid saturation and crackling of the microphone.

You say that you abandon the direct sound, but I want to tell you that in my community which currently uses ts3 at least 30% are obliged to activate the direct sound to have a correct quality. It might be a good idea to keep this option.

If it helps you to find the problem. Here are my TS and Windows settings that work correctly.

sound1 sound2 sound3

post moved by moderator

Hey, recently uses the new teamspeak beta and my request is to add “capture mode” in the audio tab as per team speak3

262038650_1003714577245851_883757739215567003_n

@P_tit.Bob and anyone else.

Can you please try to set the 192 000 HZ to 92 000 (or below).
92 Khz is supported by the client and 192 Khz is far from beyond what any human being can hear.

4 Likes

moved by moderator

I decided to start using TeamSpeak 5 more than TeamSpeak 3 and it’s been a great experience overall, aside from one instance involving my microphone. When I would speak to people in my channel, they’d complain about audio glitches that are similar to the ones I’d have on TeamSpeak 3 that was fixed by using Direct Sound as my Capture Mode. What makes things interesting is that TeamSpeak 5 does not have an option regarding the Capture Mode. I use the VoiceMod Input driver which I believe was leading to the problems I had in my previous experiences. I would like the option to edit my Capture Mode on TeamSpeak 5 just like I was able to on TeamSpeak 3 to will allow me to fix my current issue with the audio quality. If this is not possible for any reason then I can understand but I would appreciate some sort of method to remedy this issue without significantly changing my driver settings.

Thank you for reading, Gage Johnson.

1 Like

moved by moderator

Basically some audio devices are not very friendly to DirectSound or Windows Audio Session. And teamspeak5 seems like it would change it automatically. For example the ASUS AI Noise-Cancelling capture would go wrong and have annoying clipping sound when using Windwos Audio Session. And rolling back to the TS3 client and switch it to DirectSound by myself the problem solved then. So I have no idea why this feature should be removed. Addictionaly on Linux there is two modes and one is actually not working at all and the other one working properly. I have to use the ts3 client when I meet the same problem.

1+ For DirectSound.

When i use WASAPI the sound is very loud and robotic.

Using DirectSound fixes everything!

96000 Hz, 2 ch, 24-bit S-LE PCM format moving to a lower Hz systemwide is not what i want.

Apparently changing to a lower Hz doesn’t even work as it seems that my sound system only provides 96000Hz (System only detected 96000Hz mode).

If DirectSound have to be gone, then there have to be an alternative backend.

twitch instagram twitter facebook