App crashes instantly after starting on M1 Mac

I used the new TeamSpeak client in closed beta very intensively. But at some point a bunch of months ago it stopped working. The client instantly crashes on start. I switched back to TS3 for a while now, but thought I’ll give it a try again. But the problem still occurs on the newest TS Client version (just installed today).

I attached my crash report here: TeamSpeak Client Crash -

Is there any workaround or fix? Seems to be rosetta related. But in the earlier versions everything worked fine.

Please use this version.


I’m referring to the TeamSpeak 5 client. Not the 3 version.

I’m already using the 3.5.7 in the meantime. But I’d like to use TS5 again. And that is crashing like described.

Sorry, i did not read carefully enough. (Moved your post back and hid the duplicate)

Make sure you have Rosetta installed. There is no version yet for M1 processors.
And download latest client from website.


Thanks, Rosetta is already installed. And I installed the latest version just today. It crashes directly on startup. I’m not sure why.

From crashdump the first lines shows illegal instruction. That’s usually the case when CPU instructions failed or are missing on hardware.

Have you tried to run it with Rosetta directly? Maybe in your case this does not happen automatically.


I executed the following command again in the Terminal:
softwareupdate --install-rosetta

After that the app stayed a little while longer open.
But it crashed anyway. This time this is the crash report: TeamSpeak Crash Report -

Don’t know why this made a difference since Rosetta 2 was definitely installed before.

You enabled in the app directly to run with Rosetta?
When does it crash? Do you connector do anything at all?
What Mac are you using?
Have you tried to delete the app completely and install it then?

Please try to delete the Client’s cache folder: Username/Libary/Caches/TeamSpeak

If nothing helps i forward it to our developers.


The app is definitely started with Rosetta. But I’m not able to configure that in any way. (That’s only possible with Universal Apps.)
It crashed directly on startup. Sometimes you can see the window, sometimes not. I made a quick video: CleanShot 2022-04-22 at 14.49.33 · CleanShot Cloud.
I’m running a Mac mini (M1, 2020) with macOS Monterey (12.3.1)

Deleting the Cache folder did not help sadly.

One last thing i can think of is to clear the settings folder completely.


I tried that as well. And it first looked like it did help, because I’ve got that welcome screen. But after accepting the terms it crashed anyway. :frowning:
Another try of deleting the preferences and starting it, did result in an instant crash again. ¯_(ツ)_/¯

So I guess it does not work.