App is not listed under Security for Microphone on Mac OS

,

TS beta 5.0.0-beta69
TS 3.5.7

Macbook M1
macOS Monterey

The microphone does not work on any of the TS versions on the M1 macbook - my voice is not heard. I tried the settings both through the microphone built into the macbook and by connecting the AirPods.
In the settings I chose both the built-in and the airpods - no one hears me.
In version 3.5.7, when checking the microphone, it shows 0 dB
In beta version 5.0.0, when checking the microphone, playing the recorded sound does nothing - it plays silence, as if I did not say anything.

In the system settings of the macbook, in the security section, there is no TS in the “microphone” list and i cannot add it.

That’s why it will not work.
The client must be allowed in there or else you won’t be able to use your microphone for it.

We never really could find out why sometimes Mac OS does not list the app in there.
Wild guess: Could be that permissions are involved. So that the user who installed it is a different one who uses it.

1 Like

No, I installed and ran under the same user. And I installed 3 different versions and each 2 times. Rebooted the macbook and did whatever. The problem is still the same.

I can not solve this for you. Searched a bit and found promising solutions. There may be out more.

You can also drag an app into the pane to add it yourself, then select the app’s checkbox.

3 Likes
twitch instagram twitter facebook