Badges not showing in Teamspeak 3 Client

Hello, guys. I’m trying to use my badges. I just redeem some badges, such as OWL and etc. But when I went to the TeamSpeak 3 client to setup them, there were no badges showed in the settings. Does anyone know how to solve this problem?

Either you are not logged in with the same account or you reset your password without the necessary recovery key. In this case all your stored bookmarks and identities will be gone and you won’t be able to access your badges too unless you make a new recovery key.

Are you to 100% connected to myTeamSpeak?
Any DNS resolveable?
Good internet connection?
Have you already started it a several times again?

It mostly worked for me, when I re-logged in — and it may can be helpful, when you restart your client once again.

It does say “The Teamspeak server dould not validate your myTeamSpeak ID”.What can I do now?
屏幕截图 2021-05-16 055629

I haven’t used TS3 in a while, but the icon (:warning:) in the bottom right corner looks like you reset your password have have not yet entered your recovery key.
If that’s the case you can either enter your recovery key to get all the synced data back or do a fallback and loose all your synced data. No matter what you do, you will keep your badges. You just need to do one of them. If you not have your recovery key anymore there is nothing anyone can do, as this is how cryptography works.

But where do I enter the recovery key?Or how do I do the fallback thing.

You gotta click on the icon in the bottom right corner and it should come up. (only if this is actually about changing password :sweat_smile:)

it says “2021/5/16 14:52:53 ProtobufRPC Warning Server at URL https://clientapi.myteamspeak.com/user responded: 502 Bad Gateway”.Is this about password changing?

I also see"2021/5/16 14:57:16 Warning Sync temporary disabled, server not reachable”

No, my bad the icon apparently looks slightly different.
Then I honestly have no idea.
But you can log into myteamspeak.com from the same device?

Also just to be clear, have you changed your password recently and if so, have you entered a recovery key or did a fallback since then?

I was able to log in to TeamSpeak webste and I haven’t changed my password recently

Stupid question but have you tried logging out and back in on the client?

yeah,I try multiple times,and reinstall the client,but still don’t work.

I see the log says
“2021/5/16 8:02:16 Warning Sync temporary disabled, server not reachable”
“2021/5/16 15:06:38 Info failed to get user integration list from server"
Is this the reason why it can’t work?

This seems to be the problem but I can not tell you why it happens.
I guess your network is configures in a way that you can not reach the required address.
As it’s Sunday TS staff is not working rn. Hopefully they can tell you more tomorrow.

Okay,but thank you for trying to help.

guys,teamspeak also telling me:
<08:14:07> The TeamSpeak server could not validate your myTeamSpeak ID. Some myTeamSpeak related services are not available.
<08:14:07> Reconnecting might solve the issue.
and i try to recconet it’s not working

twitch instagram twitter facebook