Browse online option does not show anything

Hello there,

I have a problem when I want to install some plugins like dark mode for TS3. When I go to the Addons in the options and click on the browse online button, there does not load anything. Its just a blank screen and nothing shows. I already reinstalled Teamspeak and I tried reloading the Browse online page but nothing has worked so far. Maybe someone had the same problem and knows how to fix this.

Thank you for your replies.

It seems like the integrated TS3 Browser broke with the release of the new myTeamSpeak site.

For now you should visit the site and download the plugins from there and install them manually.

I recently bought a new laptop and when I tried to install my usual addons as always, I couldn’t. Browse online section is blank, but that wouldn’t be a problem if I could install addons from somewhere else, by addons I mean just themes and icon packs, I don’t use anything else.

I even tried downloading DarkenTS theme from teamspeak site and installed it like that, but, it still doesn’t work, in ‘My Addons → Themes’ is shown but it doesn’t actually work.

What can I do to solve this problem? I am a teamspeak user for years but never experienced something like that.

I’ve heard that it is fixed on the development branch, but that update has not yet rolled out to production.


The TS3 add-ons looks empty. I can’t add a plugin. Can you help me?

But this started to happen in the old version of TS3. Is everyone experiencing this issue?

Yes because the myTeamSpeak website has received an update, which currently does not offer the direct download via the TS3 client.