Bug Report: Missing Icon of the open Teamspeak Client

I’ve discovered a bug of the all new Teamspeak where the icon of the open client is missing.
In the following picture the right picture of the taskbar is the open Client and the left icon is the icon where I can start the client when starting the PC.


I tried several things to fix this and also reported the bug in the TS-Beta Group but the suggested solutions didn’t work. I tried:

  1. Reinstalling the Client (Includes deleting the program files)
  2. “Refresh” the icon cache
  3. Deleting the icon cache as TS_Chris suggested

After looking into the third solution, the icon was there at the first start of the client, but disappeared after the second start.

Important note: At least three users have told me that they have the same issue, at one PC there isn’t even the new icon.


I’m having exactly the same problem.


i have the same problem


Unpin it from the taskbar. Then Pin it again from the start menu shortcut. If you still have the issue, delete the shortcut, and create a new one from program files/teamspeak/teamspeak.exe.

Also tried this, it doesn’t work

1 Like

Try to clear your Windows icon cache and restart your PC.

cd %appdata%/../Local
del /F IconCache.db /A:H

If this step doesn’t work just reinstall TeamSpeak without removing it.

Already did this. Clear of the icon cache was the suggestion of @TS_Chris (with the same commands) and reinstallation of the client without removing it was my first try to fix it. Both of them didn’t work. As I mentioned, clear the icon cache worked just at the first start.


I’m having the problem as well and it’s driving me up the walls

Me too… It’s so irritating don’t know why


You mean the half rendered image? Wild guess because not even one sentence was written?

That is known bug (all Location in client). The client extracts first frame of an image and shows that. But sometimes the rendering breaks.


Based on the topic, I think it’s more about the missing icon in the taskbar. :joy:

To solve the problem, you would have to clear your icon cache and make sure that the client shortcut is using the correct location, as the client installation folder has probably been moved.

1 Like
twitch instagram twitter facebook