Can No Send Pictures/files

Hi, how come i cannot send pictures or files on my TS5? It will send emoji’s but will not send pictures no matter how big or small the picture is. When I try to send a photo or file it say I do not have permission to upload such file. I am server admin.

Where are you trying to send the images to?
To a channel chat / direct chat on a server - if so which server version?
In the global chat?
How are you selecting the file?
Could you attach the exact error message?

Trying to upload an image in the chat area within a channel. Drag and drop and by selecting the image icon within the send message box. All is says is “failed to upload file 1”. If I click on the file icon next to the channel name on the right side of panel. It says insufficient premission.

And what is the version of the server you are trying to send files on?


This is the client version…

Is the server hosted by a ATHP or on your hardware?


What is your permission power for these permissions:





no clue. Where do I find that? Sorry if I sound stupid but this new TS kinda sucks.

Select the server on top, go to Permission

Go to your group


And search for the permission name


mine is at -1 and wont change

For all of them?

for the File Download Power

Yes for all of them

Please check your client log. It will have an error or warning each time you try.

Path for log is %LOCALAPPDATA%\TeamSpeak\Logs\Default


For TS5 Beta 77
When sending images to channel chat, then it is uploaded myTS. The server doesn’t matter here.
Only if it was uploaded in channel file browser and dropped from there. Then upload or download require server permissions or port forwarding etc.


I know that the images sent to myTS are independent from the permissions but he said it printed him insufficient permissions, therefore he also tried uploading it into the File Browser?

He also wrote failed to upload 1 and description says how he tried to upload it.
For me this reads like channel chat only without any file browser involved.

Edit. Did read all again.
We have different things here.

1 is failing to send to chat and the other one is clear since server is rented (ATHP mostly do not offer file transfers without extra payments).

1 Like

ok well, I guess we need to contact our TS host. Nothing seems to work. Thanks for your help guys.

The host can not help or has anything to do with it, when image can’t be send into chat.

If this only happens in the file browser or you can not open at all, then a permission is set to deny it.
Search for ft in the permissions and you will see which one is missing.

You may also gave yourself permissions in the past and set wrong values as client permission (but then you need a TS3 client to check that out).

1 Like

Well all the ft permissions are set to -1 and it wont let me change them. Says I dont have permission to change. I used to love TS but this new version is messed up.

It won’t let you change them because permission to change these got revoked.
ATHPs often do not allow file transfers as mentioned and also do not want anyone else to revert this. Which is logical.

This is nothing new and has been in there since 19th Dec 2009 :stuck_out_tongue:
Feeling old now…