Can not save audio settings on non-default device since b65

I also had this problem under windows 10. Deleting the Appdata folder was not a permanent solution for me.

moved and split by moderator

Hello !
Since the first version I use my app won’t save the audio input VAD setting idk why can u help me ?
image
Then if I clic on server/chats/notifications/fioletransfer etc etc
image

My vad setting go back to automatic

A post was merged into an existing topic: Client Beta 72 won’t start anymore

And again, Windows Update and settings are reset and won’t save anymore. Sorry TeamSpeak Staff, what you’re doing the whole day? Why has TeamSpeak 3 not this problem? I am slowly losing confidence in the software.

2 Likes

It’s actually ridiculous how this annoying problem with the very core functionality of Teamspeak has been present and reproducible for 1,5 years now for a very large portion of Teamspeak users and all they do is write “We do not have a solution, sorry!”.

2 Likes

moved

Ts5 is in need for a hotfix for the Voice Acticvity Detection So people can select and use the Volume gate instead of being forced to make it Automatic or Push To Talk

  1. Why would that need to be a hotfix?
  2. You can select Volume Gate?

It does not save the setting it will just make it automatic again when u close the settings

This is not what you described in your initial post.
There is no need to open a new thread for an old problem, see Can not save audio settings on non-default device since b65 - TeamSpeak Client - TeamSpeak.

Nonetheless, people said it only happens with virtual audio devices. You may be able to fix it by resetting TS by removing the DB. And a lot more… Just read the thread.

(FYI: It works for me and apparently for the devs themselves.)

Sooo, I fined tuned my volume gate so that my friends hear what I say every time I speak right.
But not everything else that happens in the room.
But now every time I reopen TS5 ppl keep complaining that my mic cuts out, and surely enough volume gate is no longer active and it switched to automatic bla bla, but that’s not the only issue
whenever I reopen TS5 my mic shows as always active, even when I switch to the volume gate, I have to switch to the volume gate, turn it off and on again and most of the time that works and my mic feedback works as normal.

It’s driving me nuts, especially when my mic always shows as active(I guess I’m just a bit paranoid) it was perfect until this started to happen a few weeks ago or so…

Hello,

TS5 on my end automatically re-enables “Automatic Gain Control” which causes mouse input lag.

When I disable it, it stays disabled for a few seconds but at the latest when I switch to another settings category or minimize TS5, the client re-enables it which is causing lag for mouse inputs.
I don’t use audio drivers for my onboard audio chip, at least not that I know since I deinstalled them as I am using an external DAC.
The same behavior can be reproduced in reverse for “Echo Cancellation” which stays off after enabling.

How can this be resolved?

Version: Update 5.0.0-beta73
Windows 10 Pro 22H2
GPU: GTX 1080 Ti
CPU: i7 6700k

1 Like

Is a real solution being worked on in the meantime? The problem has been known for 582 days and drives many users to the competition. I find that such solutions as deleting databases and the like are simply not an option, especially since it is not a permanent solution. I’m a big fan of Teamspeak but it’s hard to keep friends on TS when everyone with an audio interface is facing such massive problems with the basic function of a program. The intrasperte information forwarding whether meanwhile on a solution is worked is the cherry on top.

1 Like

For quite some time, my Voice Activity Detection switches to automatic mode the whole time. I need volume Gate because automatic always detects all of the backround noise.
I switch to volume gate and as soon as I leave the settings, or switch the tab and go back its on automatic again.
Anybody knows why this is happening? I will try to reinstall now, maybe that fixes it but I thought it makes sense to report the problem here.

3 Likes

What with this? All the time voice activity automatic -,–

@TS.ChrisR Did you guys try to find a solution in the 9 months since you have stated that you don’t have a solution?
It can’t be that hard to figure out. Most other programs don’t have these problems.
Especially: Why can we not select the two “different” devices in the settings, edit and save the settings separately and successfully if they are treated as different devices in the Database? Why are they bundled together in the settings but separated in the database?

Yup i have this same issue. Continuous transmission then when we switch to Hybrid/Volume gate as long as i stay in the menu for audio it stays correct but if i go back to the TS channels it then reverts back to continuous. Any ideas on how to fix?

TS5 5.0.0-beta75
Build: 1696607978

Every time I start TS5 I have an open mic, and TX light is steady on…
I have to open Settings, and toggle VAD to make it work as expected.
It has been like this since early stages. I can’t be the only one with this problem?

I have done several updates, and just reinstalled TS5 today. No change…

1 Like

I can reproduce this bug even on Linux with a pipewire filter chain - specifically werman/noise-suppression-for-voice. When selecting the virtual audio device in TS audio settings are not saved (and I can not even close the settings thanks to this…)

Verison: 5.0.0-beta76

Hi all. The shared solution that consist to change values in the file :
“C:\Users*****\AppData\Roaming\TeamSpeak\Default\settings.db”
As described by WARdZ, worked for me.

Here my json_blobs>audio_settings :

{“0”:{“mode”:“”,“device”:{“description”:“Virtual Output B L/R”,“formFactor”:2,“id”:“{0.0.0.00000000}.{79d4babe-313d-4ef7-9262-88927b4a1771}”,“interfaceName”:“Revelator IO 24”,“name”:“Virtual Output B L/R (Revelator IO 24)”},“devices”:{“Windows Audio Session”:[[{“description”:“Virtual Output B L/R”,“formFactor”:2,“id”:“{0.0.0.00000000}.{79d4babe-313d-4ef7-9262-88927b4a1771}”,“interfaceName”:“Revelator IO 24”,“name”:“Virtual Output B L/R (Revelator IO 24)”},{“aec”:false,“agc”:true,“comfortNoise”:false,“comfortNoiseLevel”:-60,“echoReductionLevel”:0}],[{“description”:“Playback L/R”,“formFactor”:3,“id”:“{0.0.0.00000000}.{dba94e35-14d3-4ef1-94a9-babe94a807db}”,“interfaceName”:“Revelator IO 24”,“name”:“Playback L/R (Revelator IO 24)”},{“aec”:false,“agc”:true,“comfortNoise”:false,“comfortNoiseLevel”:-60,“echoReductionLevel”:0}]]},“masterLevel”:0,“notificationsDevice”:{“id”:“voice”,“name”:“”},“notificationLevel”:-23,“global”:{“agcExperimentalMode”:false}},“1”:{“mode”:“”,“device”:{“description”:“Stream Mix A L/R”,“formFactor”:2,“id”:“{0.0.1.00000000}.{47e5e7ce-16c6-4dbe-895c-2e579766c9cb}”,“interfaceName”:“Revelator IO 24”,“name”:“Stream Mix A L/R (Revelator IO 24)”},“devices”:{“Windows Audio Session”:[[{“description”:“Stream Mix B L/R”,“formFactor”:2,“id”:“{0.0.1.00000000}.{fb7b9899-863b-4bcb-b829-b64d6479d9a4}”,“interfaceName”:“Revelator IO 24”,“name”:“Stream Mix B L/R (Revelator IO 24)”},{“agc”:true,“denoise”:true,“denoiserLevel”:1,“typingSuppression”:false,“vad”:true,“vadMode”:0,“vadLevel”:-30}],[{“description”:“Mic/Inst 1/2”,“formFactor”:4,“id”:“{0.0.1.00000000}.{d5f468d8-36a3-4117-909a-9b642aed85b7}”,“interfaceName”:“Revelator IO 24”,“name”:“Mic/Inst 1/2 (Revelator IO 24)”},{“agc”:true,“denoise”:true,“denoiserLevel”:1,“typingSuppression”:false,“vad”:true,“vadMode”:0,“vadLevel”:-30}]]},“ptt”:{“active”:false,“releaseDelay”:{“active”:false,“ms”:300}}}}

I changed values to obtain this :

{“0”:{“mode”:“”,“device”:{“description”:“Virtual Output B L/R”,“formFactor”:2,“id”:“{0.0.0.00000000}.{79d4babe-313d-4ef7-9262-88927b4a1771}”,“interfaceName”:“Revelator IO 24”,“name”:“Virtual Output B L/R (Revelator IO 24)”},“devices”:{“Windows Audio Session”:[[{“description”:“Virtual Output B L/R”,“formFactor”:2,“id”:“{0.0.0.00000000}.{79d4babe-313d-4ef7-9262-88927b4a1771}”,“interfaceName”:“Revelator IO 24”,“name”:“Virtual Output B L/R (Revelator IO 24)”},{“aec”:false,“agc”:true,“comfortNoise”:false,“comfortNoiseLevel”:-60,“echoReductionLevel”:0}],[{“description”:“Playback L/R”,“formFactor”:3,“id”:“{0.0.0.00000000}.{dba94e35-14d3-4ef1-94a9-babe94a807db}”,“interfaceName”:“Revelator IO 24”,“name”:“Playback L/R (Revelator IO 24)”},{“aec”:false,“agc”:true,“comfortNoise”:false,“comfortNoiseLevel”:-60,“echoReductionLevel”:0}]]},“masterLevel”:0,“notificationsDevice”:{“id”:“voice”,“name”:“”},“notificationLevel”:-23,“global”:{“agcExperimentalMode”:false}},“1”:{“mode”:“”,“device”:{“description”:“Stream Mix A L/R”,“formFactor”:2,“id”:“{0.0.1.00000000}.{47e5e7ce-16c6-4dbe-895c-2e579766c9cb}”,“interfaceName”:“Revelator IO 24”,“name”:“Stream Mix A L/R (Revelator IO 24)”},“devices”:{“Windows Audio Session”:[[{“description”:“Stream Mix B L/R”,“formFactor”:2,“id”:“{0.0.1.00000000}.{fb7b9899-863b-4bcb-b829-b64d6479d9a4}”,“interfaceName”:“Revelator IO 24”,“name”:“Stream Mix B L/R (Revelator IO 24)”},{“agc”:false,“denoise”:false,“denoiserLevel”:0,“typingSuppression”:false,“vad”:true,“vadMode”:0,“vadLevel”:-30}],[{“description”:“Mic/Inst 1/2”,“formFactor”:4,“id”:“{0.0.1.00000000}.{d5f468d8-36a3-4117-909a-9b642aed85b7}”,“interfaceName”:“Revelator IO 24”,“name”:“Mic/Inst 1/2 (Revelator IO 24)”},{“agc”:false,“denoise”:false,“denoiserLevel”:0,“typingSuppression”:false,“vad”:true,“vadMode”:0,“vadLevel”:-30}]]},“ptt”:{“active”:false,“releaseDelay”:{“active”:false,“ms”:300}}}}

in my case > I could now switch voice detection mode in what I would, WITHOUT that automatic mode coming again… again… again…

Thanks so much !