Cannot connect

Hi, i have a teamspeak 3 server installed on ubuntu 20.04.

Using putty, the server is status is active but i cannot connect. Any help would be appreciated

“2021-10-21 17:49:59.930387|INFO |VirtualServerBase|1 |listening on 0.0.0.0:9987, [::]:9987”

"2021-10-21 17:49:58.696152|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.5 (2021-05-17 08:13:36)
2021-10-21 17:49:58.696285|INFO |ServerLibPriv | |SystemInformation: Linux 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 x86_64 Binary: 64bit
2021-10-21 17:49:58.696314|INFO |ServerLibPriv | |Using hardware aes
2021-10-21 17:49:58.697105|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSpeak Systems GmbH
2021-10-21 17:49:58.697144|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-10-21 17:49:58.697481|INFO |DatabaseQuery | |checking database integrity (may take a while)
2021-10-21 17:49:58.736248|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2021-10-21 17:49:58.736440|INFO |Accounting | |Licensing Information
2021-10-21 17:49:58.736462|INFO |Accounting | |licensed to : Anonymous
2021-10-21 17:49:58.736474|INFO |Accounting | |type : No License
2021-10-21 17:49:58.736497|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2021-10-21 17:49:58.736509|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2021-10-21 17:49:58.736520|INFO |Accounting | |max virtualservers: 1
2021-10-21 17:49:58.736530|INFO |Accounting | |max slots : 32
2021-10-21 17:49:59.866455|INFO | | |Puzzle precompute time: 1108
2021-10-21 17:49:59.867062|INFO |FileManager | |listening on 0.0.0.0:30033, [::]:30033
2021-10-21 17:49:59.877389|INFO |Query | |Using a query thread pool size of 2
2021-10-21 17:49:59.930650|INFO |Query | |listening for query on 0.0.0.0:10011, [::]:10011
2021-10-21 17:49:59.930907|INFO |Query | |listening for ssh query on 0.0.0.0:10022, [::]:10022
2021-10-21 17:49:59.930998|INFO |Query | |listening for http query on 0.0.0.0:10080, [::]:10080
2021-10-21 17:49:59.931069|INFO |CIDRManager | |updated query_ip_allowlist ips: ( ip removed )/32, ::1/128, "

hardset the servers ip in the ini file and then try

tsdns_settings.ini.sample?

i made a server.ini file

used

machine_id=
default_voice_port=9987
voice_ip=77.REMOVED
licensepath=
filetransfer_port=30033
filetransfer_ip=77.REMOVED
query_port=10011
query_ip=77.REMOVED
query_ip_whitelist=query_ip_whitelist.txt
query_ip_blacklist=query_ip_blacklist.txt
dbplugin=ts3db_sqlite3
dbpluginparameter=
dbsqlpath=sql/
dbsqlcreatepath=create_sqlite/
dbconnections=10
logpath=logs
logquerycommands=0
dbclientkeepdays=90
logappend=1

still no luck

tried this:

./ts3server_startscript.sh restart
Stopping the TeamSpeak 3 server .
done
WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
!!!
Starting the TeamSpeak 3 server
Warning - name ‘query_ip_whitelist’ from file ts3server.ini is deprecated (but understood), please use the ne w name ‘query_ip_allowlist’ instead.
Warning - name ‘query_ip_blacklist’ from file ts3server.ini is deprecated (but understood), please use the ne w name ‘query_ip_denylist’ instead.
TeamSpeak 3 server started, for details please view the log file
[email protected]:/home/teamspeak# ./ts3server_minimal_runscript.sh inifile=ts3server.ini &
[1] 150947
[email protected]:/home/teamspeak# Warning - name ‘query_ip_whitelist’ from file ts3server.ini is deprecated (bu t understood), please use the new name ‘query_ip_allowlist’ instead.
Warning - name ‘query_ip_blacklist’ from file ts3server.ini is deprecated (but understood), please use the ne w name ‘query_ip_denylist’ instead.
2021-10-21 21:58:40.942300|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.13.5 (2021-05-17 08:13:36)
2021-10-21 21:58:40.942377|INFO |ServerLibPriv | |SystemInformation: Linux 5.4.0-88-generic #99-Ubuntu S MP Thu Sep 23 17:29:00 UTC 2021 x86_64 Binary: 64bit
2021-10-21 21:58:40.942417|INFO |ServerLibPriv | |Using hardware aes
2021-10-21 21:58:40.943146|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, ©TeamSp eak Systems GmbH
2021-10-21 21:58:40.943195|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
2021-10-21 21:58:40.943487|INFO |DatabaseQuery | |checking database integrity (may take a while)
2021-10-21 21:58:40.982533|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
2021-10-21 21:58:40.982753|INFO |Accounting | |Licensing Information
2021-10-21 21:58:40.982788|INFO |Accounting | |licensed to : Anonymous
2021-10-21 21:58:40.982807|INFO |Accounting | |type : No License
2021-10-21 21:58:40.982839|INFO |Accounting | |starting date : Thu Oct 1 00:00:00 2020
2021-10-21 21:58:40.982865|INFO |Accounting | |ending date : Tue Nov 1 00:00:00 2022
2021-10-21 21:58:40.982890|INFO |Accounting | |max virtualservers: 1
2021-10-21 21:58:40.982913|INFO |Accounting | |max slots : 32
2021-10-21 21:58:41.482889|ERROR |Accounting | |local accounting reports an already running instance, instance will shutdown
2021-10-21 21:58:41.997828|INFO | | |Puzzle precompute time: 993
2021-10-21 21:58:41.998421|ERROR |FileManager | |bind failed on 77(REMOVED); reason: Address al ready in use
2021-10-21 21:58:41.998563|CRITICAL|VirtualSvrMgr | |Could not start file manager 258 no network port avail

You don’t have to bind the server to a specific network address.
It does automatically select the assigned IP address(es).

You should make sure your systems firewall isn’t blocking inbound connections on your default UDP port 9987.

Just check the default input policy and open the mentioned port.

This is also required for your firetransfer port which is using TCP as protocol.

best to reinstall everything again, or just delete the ini that was created?

You can just remove the entered IP address and leave the parameters empty.

Make sure to stop the server always properly using the startscript. Do not kill the process.

(edit)

Please don’t run the server as root as the warning says.
This has security reasons but doesn’t cause your issue.

ok mate, noted, thanks.

ive setup firewall for

ts3 UDP 9987

i still cant connect, i setup the firewall rule via my host control pannel. ill need to find a command line for ubuntu to double check/test the port to be sure

working mate, needed to restart operating system, thanks :smiley:

2 Likes

are you able to help get the server to restart with the server each time?

ahh sorry mate thought you would have already forward the ports and maybe this will help with your latest ? https://www.youtube.com/watch?v=56h08S8sRM8

no problem, appreciate the help. thanks

1 Like

you could skip to the endish where they do the sys.d that what you are after

thanks man

edit: all good now, thanks

2 Likes

Yes, just create a service which in controlling your application.
Take a look into the follow thread:

working mate, awesome!

do i need to :

sudo systemctl stop teamspeak.service
sudo systemctl disable teamspeak.service
sudo systemctl daemon-reload

If you wanna start or stop the service, please use systemctl to do so.

start the service

sudo systemctl start teamspeak.service

stop the service

sudo systemctl stop teamspeak.service

current service status

sudo systemctl status teamspeak.service

The service will automatically start with your system after a short delay.

sudo systemctl disable teamspeak.service
sudo systemctl daemon-reload

These two commands are only required if you wanna remove the service of your system.

3 Likes

thanks man

1 Like
twitch instagram twitter facebook