Can't connect ot chat (invalid login / Internal server error)

moved to be own thread


I also can’t connect to the TeamSpeak chat. The error message says there are problems with my internet connection but everything except TeamSpeak chat is working. Maybe it’s maintenance so I waited but after over 24 hours I went troubleshooting.

Before I get recommendations like restart PC or delete roaming/local (cache) - all already done… and I have the same problem on another PC.

The error message in the log confirms a problem with the Matrix server:
error=Internal server error errorCode=M_UNKNOWN


[2023-04-07 11:46:03.230] [info] Matrix client create:
[2023-04-07 11:46:03.244] [info] Failed to restore store from save data: invalid login data
[2023-04-07 11:46:03.244] [info] Creating fresh store
[2023-04-07 11:46:03.244] [info] new crypto account on init - fresh
[2023-04-07 11:46:03.245] [info] created new group session storage
[2023-04-07 11:46:03.255] [info] connect: ts_chat_id=2 displayname=Sponge-Manu presence=online
[2023-04-07 11:46:03.785] [warning] TSChat_Connect failed: Protocol error: error=Internal server error errorCode=M_UNKNOWN softLogout=false retryAfterMs=0
[2023-04-07 11:46:03.785] [error] Connection failed: err=1
[2023-04-07 11:46:03.787] [info] stop: ts_chat_id=2
[2023-04-07 11:46:03.804] [info] Save data path: specifier=XXX
[2023-04-07 11:46:03.820] [info] destroy: ts_chat_id=2
[2023-04-07 11:46:23.828] [info] TSBindingBrowserTSChat::create scHandlerId=0 server_identifier= specifier= endpoint=__CENTRAL__
[2023-04-07 11:46:23.829] [info] Save data path: specifier=XXX
[2023-04-07 11:46:23.829] [info] Matrix client create:
[2023-04-07 11:46:23.842] [info] Failed to restore store from save data: invalid login data
[2023-04-07 11:46:23.842] [info] Creating fresh store
[2023-04-07 11:46:23.842] [info] new crypto account on init - fresh
[2023-04-07 11:46:23.842] [info] created new group session storage
[2023-04-07 11:46:23.856] [info] connect: ts_chat_id=3 displayname=Sponge-Manu presence=online
[2023-04-07 11:46:24.402] [warning] TSChat_Connect failed: Protocol error: error=Internal server error errorCode=M_UNKNOWN softLogout=false retryAfterMs=0
[2023-04-07 11:46:24.402] [error] Connection failed: err=1
[2023-04-07 11:46:24.416] [info] stop: ts_chat_id=3
[2023-04-07 11:46:24.432] [info] Save data path: specifier=XXX
[2023-04-07 11:46:24.448] [info] destroy: ts_chat_id=3
[2023-04-07 11:47:04.464] [info] TSBindingBrowserTSChat::create scHandlerId=0 server_identifier= specifier= endpoint=__CENTRAL__
[2023-04-07 11:47:04.465] [info] Save data path: specifier=XXX
[2023-04-07 11:47:04.465] [info] Matrix client create:
[2023-04-07 11:47:04.479] [info] Failed to restore store from save data: invalid login data
[2023-04-07 11:47:04.479] [info] Creating fresh store
[2023-04-07 11:47:04.479] [info] new crypto account on init - fresh
[2023-04-07 11:47:04.479] [info] created new group session storage
[2023-04-07 11:47:04.514] [info] connect: ts_chat_id=4 displayname=Sponge-Manu presence=online
[2023-04-07 11:47:05.057] [warning] TSChat_Connect failed: Protocol error: error=Internal server error errorCode=M_UNKNOWN softLogout=false retryAfterMs=0
[2023-04-07 11:47:05.057] [error] Connection failed: err=1
[2023-04-07 11:47:05.073] [info] stop: ts_chat_id=4


The issue is solved
The day when this began our host killed our docker containers and partly crashed our database.
We restored it and run a check over it and nothing seem to have failed here.

But unfortunately for some Matrix accounts the database was broken.

The whole database got fixed (we hope)

original message

@Sponge-Manu but it also says that your login data which is stored seems to be wrong.
You never played with a non TS client for Matrix (asking that for reasons you might know)?

Have you tried to logout of the myTS account and login again to create no login for your devices?


@TS.ChrisR This is not an explanation for the problem. In the past I have used Element but not in the last few weeks. I have the problems since yesterday and I have not changed any credentials.

A friend also used Element and he can log in. Because of your message he tried to log in to Element and switched back to TeamSpeak and he has no problems.

A search for M_UNKNOWN means that it is not a client issue but an instance/synapse one.

correct data:

wrong data:

@TS.ChrisR I still can’t log in so I continued my review (e.g. traffic analyzed, requests compared and reproduced, other accounts tried, installed on clean system, …)

The login data can’t be wrong, as already seen in my last message, so the requests to were boring. The chat server responds 403 Forbidden with incorrect login data, with correct data actually 200 OK but not with my account. I get 500 Internal Server Error as an response. With other accounts I can log in and out with both TeamSpeak and Element.

However, this is not an isolated case. I know another case with the same problem with the difference that works with one PC. He can not log in with another PC. It works with PC1 but not with PC2. An analysis of the requests confirms that PC1 does not log in, an existing access_token is used. If I delete the folder AppData\Local\TeamSpeak\Cache\Default, then PC1 get the same response: 500 Internal Server Error

wrong data:

POST /_matrix/client/r0/login
403 Forbidden

correct data with my account:

POST /_matrix/client/r0/login
500 Internal Server Error
{"errcode":"M_UNKNOWN","error":"Internal server error"}

correct data with aother account:

POST /_matrix/client/r0/login
200 OK

I suspect a connection with the latest maintenance work. Maybe my TeamSpeak client also used a cached access_token a few days ago until it became invalid. How do I get back into my chat account?

Any solution for me? How do I get back into my chat account?
Who can I contact to resolve the issue? or can someone contact me?

Sry i got no good news for you.

No. We have to check your account.
But this won’t happen before next week. Have that on my list to contact IT about it.

You can’t.
Maybe we can fix or reset it next week. Can not promise you anything at this point.

This will happen next week.

Edit1 : Can you please try something?
Warning: MAYYYBEE this may mess up the situation a bit more.

Open the Dev (type dev in search bar) menu and on bottom delete your homebase. And then try to set central again.

Side note:
I did not contact anyone who is currently on vacation because a non TS client was involved and these cases have low priority for us. We wasted enough time fixing accounts where people did use use other software and broke them that way. But IT will have a look at this next week.

At the moment it still looks like your login data are corrupted or false. No matter if you got the unknown error with that. The error follows and isn’t the first one. I may be wrong. Only IT can tell next week.

No matter what you tried there, the system itself does not seem to be broken.
Else we would have more complains and for now you are the only *proven case (ignoring Zuckermutter’s report here because no logs are given and so it could be maybe another case).


I am grateful for any help and try everything, but this didn’t help…

I wonder how you think that another client has something to do with it. The reset and the switch to Matrix was on 01.02.2022, over one year there were no problems with it. Matrix is an open standard. Of course, I and many others have used Element as well … and as I said, that was some time ago. Why now? I hope not that TeamSpeak locks accounts when other clients are used. Only Apple can afford a closed ecosystem. :smirk:

Thank you for the message. I will wait…

We are not always using latest Matrix version on server and Element as an example has features we don’t even use or will support in our client. And also Matrix and we aren’t bug free…

So there is a big chance to break accounts or rooms. We never know and so we don’t support any 3rd party client.

So as long we don’t support all Matrix features, we won’t investigate in possible 3rd party issues.



Our IT looked into your Account and we see that a script (can’t be a client from the timings) still tries to login with invalid login data.

There are still logins going on? What are you doing here?

Even the login you showed with client log has the invalid login data on our worker(s).

It could be that your scripted logins without TS Client which generate a new device id each time filled and broke your account. This how it looks for us so far.

We don’t know for sure why your account broke. We do not have any explanation…

We need to evaluate if we can offer you a reset of that account…

For us it is hard to believe that no 3rd party software was used for a while. There are logins before your reported issues and after it… We warned many times that non TS Clients can break accounts. This case seems to be another good example :confused:


I want to draw your attention to the fact that it’s not April Fool’s Day. You can stop teasing me. I’m starting to get the feeling that you’re trying to accomplish something else…

Of course I have the TS5 client open when I’m on the PC - it tries to log in all the time. I have no script or other client running that tries to log in except TS5 itself. It must have been the 06.04. from one day to the other I see only “Disconnected”. To show you what I mean I sent POST requests manually from different accounts - it is NOT due to wrong login data. 403 != 500

I don’t use a script so it must be TS5. In addition a device ID is assigned by Synapse on the HTTP 200 response when you log in, not created by the client. Unfortunately, I don’t get 200 only 500 …

POST /_matrix/client/r0/login
200 OK

If you think it’s because there are too many devices, can you logout them all? Actually possible via the API but I can not log in…

.../devices          > Gets information about all devices for the current user.
.../delete_devices   > Deletes the given devices
.../logout/all       > All devices for the user are also deleted.

If reset is necessary: I am an admin in some chat rooms. What do I do if I lose the permissions in these rooms after the reset?

1 Like

As said in voice

Matrix password reset and clearing all the devices did not help.
IT will look deeper into your DB entry and old backups. Maybe we find more details.

We/I will contact you again.

Sry for your circumstances with the situation and circumstance you got from myself :stuck_out_tongue:


The issue was resolved.

Updated my first reply for details.