Can't find my server

I have server address but its not there

Can you give us a little more information? Which server are you looking for?

If you mean a 10 slot server that you created via TeamSpeak 5 at the beginning of the closed beta, I’m sorry to say that they have been disabled and it is unknown if they will ever become available again.

SERVIER ADDRESS IS: OCANADAMYLEAGUE.TYPEFRAG.COM.8885

I actually meant you should explain if it is your server etc or not.

However, I just tried to connect to the server address. The server is online but password protected. Note that you have to separate the port (8885) from the domain by a colon not a dot (domain:port).

I don’t know what im doing wrong but it not working

what exactly did you type to find it

-> you should use a : before the 8885

I tried that

it works for me…

Don’t you even get the message that the server is password protected?


Is it your own server and do you have the password or the permission to skip the password?

If yes, make sure that

  • your client is on the latest version
  • you are sure to enter the address and port correctly
  • your firewall does not block your client
  • your ISP allows the client

Otherwise you should try to connect to the server via query and remove the password.


However, if it’s not your own server, you don’t have query access and you don’t have permission to skip the password, then you need to contact the server admin of the TeamSpeak server and ask them to remove the password.

twitch instagram twitter facebook