Cant see the new TS3 Badge (TEAMSPOOKY)

hey since the new icon came out i cant see it on any Server either for me or other Users. I have the newest ts3 version (3.5.2) and have everything related on and tried to fix it my self. Ive tried to activate the code again but its already used but still i cant see it in my badge list

You can clear the cache so it will download the badges again.
C:\Users\AccountName\AppData\Roaming\TS3Client\cache\badges
Or just download the icons manually and put the in the cache/badges folder.
https://badges-content.teamspeak.com/be932556-dfa9-4dc6-afd0-98de0ab25777/PolTeamgeist.svg
https://badges-content.teamspeak.com/be932556-dfa9-4dc6-afd0-98de0ab25777/PolTeamgeist_details.svg

By the way, latest client is 3.5.3

2 Likes

Just in case: Did you choose it to display? (My friends had cases when they did not choose a new icon as active and then asked where is it?)

1 Like

Your right its 3.5.3.

I cleared the cache and tried to connect to a Server an see if it change anything but still the icon didnt show up even after i copied the file in to the cache folder. Its just for this Icon that dosent work for me all the other icons work normally and i can display all the other ones.

Please make sure that you have Send “myTeamSpeak ID” is enabled in your bookmark.

1 Like

already have it on, i tried many ways and couldnt find any reason why its not working

twitch instagram twitter facebook