Can't start a TS local server

I downloaded a server as a ZIP file from official TeamSpeak website, extracted it as it says in tutorial, tried to start it as administrator but it just won’t open. I tried deleting and downloading it 2 more times, but… the same problem. I checked my firewall, task manager, opened ports in WI-FI router settings, but nothing worked. Anyone knows how to fix this?

Please go into the log folder and read (or share) what the logs tell you.

1 Like

Read one of them it tells you what happened and what to do.

Ps on Windows you should see this when starting the server.

As long you did not what the log files told you and when you reject it, then the server will stop.


This thing didn’t even pop-up. Does it takes that long to start this thing up?

Every time i try to open it, nothing pops up, and it just sends the log again and again.

Please open and then read one of the files you showed to us.

1 Like

Idk how can this be possible, cuz I have this file

Maybe this folder is different because OneDrive is using it.

Please pause or stop OneDrive or turn off synchronization for this folder and try again.

1 Like

Ok, I’ve tried this, even reloaded my PC, but it’s still sending logs.

The only other explanation I have is that the file has permissions set and the user who runs the server doesn’t have permissions to read the license.txt and maybe more files.

When extracting the server do not make this as Admin and do not run the server as Admin then.


  1. Read the license.txt and go on with step 2 when you agree to the license agreement.

  2. Create a new text file in server folder.

  3. Rename this file from XYZ.txt to .ts3server_license_accepted

  4. Run the server again

…But I think the server will miss more files.

1 Like

Tried, still the same. I’ll try to delete and download the server again

Tried it on new server, still didn’t work.

I have no clue what is going on there on your system. Sorry.

What you could try is following but i still think server will stop or break at some point.
Always start the server with following parameter


Can be done in a shortcut to the binary like that

Or added as parameter in console.


Finally! This fixed my problem, thank you!

1 Like