Channel with / in name can not be used for connection

Since November 15th I encounter strange bug in new TS Client. When I connect to server, every time I’m getting put to server’s default channel and not the one I’ve set in bookmarks. In TS3 it doesn’t happen, but in TS5 it happens with every bookmark.

The day I discovered this bug I contacted via email with TS Support but since then I’ve seen no response whatsoever, which is kinda annoying.

The only thing I did since switching to TS5 was improving Security Level from 25 to 27 just for the sake of it. The thing is that I use the same identity on both TS3 and TS5 (in 5 bookmarks to be exact) and only in TS5 this bug happens.

It’s annoying that this is known for at least 2.5 months (since this is how long ago I contacted Support) and still it wasn’t patched or even (I think) described anywhere.

This is how it looks in my settings:
bookmark_problem
(some things were censored because they might contain personal information).

Thanks for reading!
_ ニャー _ <3

2 Likes

Try connecting to the server, switch to the desired channel, open the edit bookmark for the server (as in your screenshot), and then click the icon next to the default channel input field.
Disconnect and connect to the bookmark, see if you get put in the correct channel.

3 Likes

No, it doesn’t help. Tried it at least 20 times over last 2 months and even edited this in TS3, no help…

Where is the backslash in the screenshot of your example bookmark coming from?

It was like that when I imported every setting from TS3. Even if I delete this backslash, it doesn’t help if anybody would like to ask that.

Edit: It’s like in UNIX when you have slash in filename or folder name, cause channel “channel.005.mp3” is in group “/public”. And yes, these are real channel names.

This is what I meant with naming channels and groups of channels:

1 Like

TS5 seems to have some problems with the slash in the channel name. I did some testing with a similar channel structure, and was able to reproduce the problem.

TS3 = Create Bookmark = Set Default Channel = Result: [spacer0]/\/public/channel.005.mp3
TS5 = Use Bookmark = Result: Landing in Root channel
TS5 = Connect to correct channel = Edit Bookmark = Set Default Channel = Result: [spacer0]//public/channel.005.mp3
TS5 = Use Bookmark = Result: Landing in [spacer0]

But there’s a catch. It was working until updating to beta.16 from beta.15 and so on from beta.12 and until improving Security level.

I doubt very much that an improvement in the Security level had anything to do with the broken bookmark. I’d say that something was changed within the code of TS5 that introduced a different behaviour, but that is well beyond my scope. @TS_Chris

2 Likes

Yes, this doesn’t sound right but it is like I’m saying :sweat_smile: And this is the funniest thing.

Just for clarity:
beta.12 - works fine
beta.13 through beta.15 - still fine (but if I remember correctly, I missed these versions and went straight to beta.16, even if I was checking for updates at least once a day)
beta.16 - still fine
beta.16 after improving SL - well, crap… no longer works
today - still does not work properly

Maybe it will be fixed in a future update, I’ll wait, I have plenty of time. The only thing is that it’s somewhat inconvenient.
But thanks for your help Brady.

2 Likes

My Channel name is this one:
[cspacer]● AFK/Anderer TS/Beschäftig ●
I set this channel to default join channel, but when I join I only land in the Default Channel of the Server. I think it has to do with the ‘/’ or caracter in the channel-name

1 Like

I have the same problem, as soon as / is in the channel name, the client connects to the default channel.

1 Like

You can simply escape the character using a \ before.

For example:

Thought that bug was fixed already…

TS 3 does this but if I sync it to TS5 it doesnt work anymore
Also If you set it with the “My current Channel” button it doesn’t work

TS3 saves the channel ID when the default channel was set when connected to the server and you are in the channel.
TS5 only uses the name (downgrade), so when the channel gets renamed (for example because it hast a date/time stamp in the name), you will get thrown in the default server channel instead.

Hello, my colleague @tatayer and @Karazhan we found a bug on Default Channel

(TS5) [spacer4]Administration/╚-● AFK/ABS
(TS3) [spacer4]Administration/╚-● AFKVABS

On TS5 client, it cannot find the channel

Capture2

cordially

I found a solution for this bug.
All you have to do is enter the server, disconnect from it and then connect again, then it sends you to the channel you set. However, I would ask to correct this bug.

twitch instagram twitter facebook