[Codec] Opus Music - User very quiet

Hello guys,

I have a problem with the Opus Music Codec. We run a music bot on this channel and when a user speaks on this channel it is always extremely quiet and cannot be understood. Even adjusting the volume does not solve the problem. Do you have a solution ready for this problem?

Greetings, Killer0561

Please do not use the Music Codec for Talking. There is no AGC active to manage the loudness of clients.

1 Like

What is AGC?

AGC (automatic gain control)

Is there no way to activate the AGC in an Opus Music Channel? We just use the music channel for both listening to music and talking. Because with Opus Voice the music sounds extremely bad.

No. We just removed it because a lot of users complained that their music bot changes the volume and every user had to change their settings.

This is why we decided to deactivate that feature completely in channels where user are not supposed to talk.

1 Like

Hm ok. What should I do best now? How did you set up the music bot to talk to music and people at the same time? I look forward to your suggestions.

Dude, there’s no perfect solution for anybody out there.

Change the codex to Opus Voice if you wanna talk in the channel or Opus Music if you listen to music.
Both at the same time doesn’t make sense.

If you gonna talk in a channel while music plays, the music has to be silent enough to understand other clients talking anyways, which makes the discussion about the music quality obsolet (on Opus Voice).

I don’t like AGC, too that’s why I stay on 3.3.2 but by definition Opus Music is optimized for music and not for human conversations.

1 Like

The best solution for me was now: I deactivated the automatic volume adjustment and set each user separately. So I can talk to people in both Opus Voice and Opus Music without anyone being too quiet. For me, the issue is solved. Thank you for your answers.

greetings, Killer0561

twitch instagram twitter facebook