Connecting to servers on startups getting broke

sometimes it doesn’t work to connect to a server on startup after a while the parameter is getting ignored.

Windows 11
5.0.0-beta74 • Windows

1 Like

can confirm this.

also, connecting to a server at startup takes an extremely long time & sometimes doesn’t work at all.

Can provide several additional details.
In my case:

  1. If i connected to server and connect on startup is disabled - after client relaunch i see ‘paused’ server. need to click on it to connect on next client launch. That strange, but ok

  2. If i connected to server and connect on startup is enabled - after client relaunch i’ll automatically join server on next client launch. that ok.

  3. if i disconnected from server and connect on startup is disabled - no server in connection on next client launch. thats ok.

  4. if i disconnected from server and connect on startup is enabled - no server in connection (screen from step #3). It is bug, because when i selected connect on startup, i want automatically connect to server on next client launch, even if i exit server during last session.

Depends on what setting you have active. If “Only to restored activities” is active, then it behaves right.

You can find it under the dev menu. Type dev into the search bar and open Developer Tools

Your screenshot doesn’t show the activity that is not connected?

  • See above and check that setting out.

Referencing an option in the developer tools might not be that helpful…
Why is this not in the normal behavior settings? And why is the default not the same as in TS3 - Connect every time?


hmm… I tried to change to “everytime”! but it still doesn’t let me connect to it.

I definitely agree with @Gamer92000 why doesn’t it connect to it every time?

btw issue still exists in the version 5.0.0-beta75-rc4 • Windows

Found the problem: (This is actually a bug)

It only auto connects to a completely closed server when

  • Connect every time is turned on AND
  • the bookmark is in the root and not in any subfolder

The second part is the problem here. When the bookmark is not in the root it will apparently not be considered for auto connect.


@Gamer92000 Thanks can reproduce this as long the server is no longer a activity.

@OLFMSQL & @qeinz Are your’s also in a folder?



1 Like


1 Like