Disabling whispers bug

I’m trying to disable whispers, but people are still able to whisper each other even tho:
i_client_whisper_power is never higher than i_client_needed_whisper_power

I’ve tried to remove i_client_whisper_power, put in a negative number, put it at 1.
All while i_client_needed_whisper_power is set to 120.
People can still whisper everyone!

There is no channelgroup, or anything giving them whisper power. So what am i doing wrong? Is this a teamspeak bug?

Set a value of 75 for needed whisper power in every other group.

Or set a negative value for whisper power in all other groups.

set i_client_whisper_power to -10 on all server groups.

Just tried this. Whispers still work

Just try this:

Right click on i_client_whisper_power and select “Remove Permission”. Double click on i_client_needed_whisper_power and set the value to some positive integer, like 50 or 75. Now repeat this for every server group there is.
If you as a server admin still want to be able to whisper, do not remove i_client_whisper_power from the server admin group and make sure its value is greater than or equal to any i_client_needed_whisper_power.

Please note: You can always block all whispers to you without touching the permissions by clicking on Settings -> Options -> Whispers -> Deny Everyone. In that case all of you would have to do that though.

That’s the wierd part. I’ve tried lower numbers, negative numbers, removing the permission. Everyone can whisper everyone ignoring the whisper permission.

I know it can be set to deny locally, but we want to help everyone in the community to not have this problem.

Like look at this. This permission group can still whisper everyone…
Permissions

Just a note: Every other group have needed at 75 as well…

DM Me i will try you to help. :slight_smile:

That’s a us known bug where negative whisper power does not compare right to positive needed whisper power.

Just set a whisper power of 0 to fix this for yourself.

1 Like

But if i put needed at 75, and give everyone 1 - it still buggs out :confused:

Please show a full permissions overview (right-click on user in server tree) of that user who has the whisper power and one who should not get a whisper.
Both users must be in same channel for this!

1 Like

Both users can talk to each other with whispers.
These are the permissions. Also uploaded are the exports of the poermission view.
Links:
Mad0 (Guest): https://pastebin.com/36CW7dPV
Lukas (Admin): https://pastebin.com/Em0PaqLJ
Pics:

So far as i can see your permissions look as they should.
Whisper should not work and they should hear “no whisper target found”.

But i fail to reproduce this on server 3.12.1 and client 3.5.3. Always get that notification and the target never sees or hear any whisper.

Are you on the latest server? I missed some permissions in the overview.

1 Like

I can see we’re still on 3.11.0
I can try upgrading over the night.

Just for your info. Server 3.13.0 will fix the issue completely.
Negative and positive whisper power are now checked right again.

1 Like
twitch instagram twitter facebook