DNS Problem on Win 10 x64 | dns:ts18.d11.ts-server.de

Hello Community,

I guess I will need some help with figuring out a problem with TeamSpeak.

I’ve got problems joining a specific TeamSpeak Server.
The Server Address is: ts18.d11.ts-server.de:1227

The Server is up and running and a few month ago everything worked fine for me.
I’m not sure what has changed in between the last 3 or 4 months, but the hostname won’t resolve any more on my computer.
Microsoft Windows 1909 (Build 18363.693) [Version 10.0.18363.693] - 64 Bit
TeamSpeak 3 v3.3.2 (25.08.2019) - 64 Bit

I tried to locate the problem, since my friends got no problem at all.

  • I tried several DNS Providers with DNSSEC like Google and Quad9 without success.
  • I tried my default ISP Providers DNS with default settings without success.
  • I’m not able to join with another pc within my local network, but I’m able to join on my mobile TeamSpeak app on iOS (mobile data deactivated first so the dns cache won’t have an cached results and should use the same name server)
  • the server list is synced via myTeamSpeak so the iOS app used the same address entry. I checked it adding new entries and deleting some, sync works fine.

I also tried using a vpn (hide.me - Deutschland) wich worked fine
<15:45:08> Versuche den Hostnamen ts18.d11.ts-server.de aufzulösen
<15:45:12> Versuche zum Server auf ts18.d11.ts-server.de:1227 zu verbinden
<15:45:12> Willkommen auf dem TS Server von BnW.

Finally, I tried to figure out if it’s maybe a Problem the TS hoster should fix.
I live a few miles away from my friends, have cable internet instead of glass fiber and have a different ISP (Vodafone) - they have (Deutsche Glasfaser).
mxtoolbox.com | dns:ts18.d11.ts-server.de

Since I have already spent about 8 hours trying to figure out the problem, I’m kind of open to help now.
Is there anything I can do?
Is the problem some sort of protection within the “TS Client” or is it something the voice server hoster must fix?

Thanks for any kind of help.

Best regards

ts3client_2020-03-08__15_47_24.069310.log | failed try


2020-03-08 14:47:24.069310|INFO | | |TeamSpeak Client 3.3.2 (2019-08-25 21:13:34)
2020-03-08 14:47:24.069310|INFO | | |SystemInformation: Windows 10 (18363) x64 (AMD or Intel) Binary: 64bit
2020-03-08 14:47:24.069310|INFO | | |Using hardware aes
2020-03-08 14:47:24.114190|DEBUG |Direct Sound | |setting timer resolution to 1ms -
2020-03-08 14:47:24.170064|INFO | | |*** Time [SPAWN_EVENTCONVERTER]: 102
2020-03-08 14:47:24.187993|INFO |ClientUI | |OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce RTX 2080 Ti Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE
2020-03-08 14:47:24.273789|INFO |Addons | |Checking for addon updates…
2020-03-08 14:47:24.284734|INFO |Plugins | |Loading plugin: clientquery_plugin_win64.dll
2020-03-08 14:47:24.286728|INFO |Query | |listening on
2020-03-08 14:47:24.286728|INFO |Plugins | |Loading plugin: gamepad_joystick_win64.dll
2020-03-08 14:47:24.320668|INFO |Gamepad Plugin| |Found client raw input wnd proc
2020-03-08 14:47:24.320668|INFO |Gamepad Plugin| |Cleared device list
2020-03-08 14:47:24.321667|INFO |Gamepad Plugin| |Found device \?\HID#VID_051D&PID_0002#9&16CE9F7&0&0000#{4D1E55B2-F16F-11CF-88CB-001111000030}
2020-03-08 14:47:24.321667|INFO |Plugins | |Loading plugin: TS3MassMover_win64.dll
2020-03-08 14:47:24.322664|INFO |Plugins | |Loading plugin: teamspeak_control_plugin_win64.dll
2020-03-08 14:47:24.322664|INFO |Gamepad Plugin| |Found device \?\HID#VID_046D&PID_C539&MI_02&COL03#8&C4E5B0E&0&0002#{4D1E55B2-F16F-11CF-88CB-001111000030}
2020-03-08 14:47:24.323661|INFO |ControlPlugin | |Control Plugin started, accepting connections
2020-03-08 14:47:24.323661|INFO |Plugins | |Loading plugin: AutoAway_win64.dll
2020-03-08 14:47:24.323661|INFO |Plugins | |Loading plugin: crosstalk_win64.dll
2020-03-08 14:47:24.324659|INFO |CrossTalk | |init
2020-03-08 14:47:24.330670|INFO |CrossTalk | |No translation available.
2020-03-08 14:47:24.330670|INFO |CrossTalk | |Position Spread: enabled: true
2020-03-08 14:47:24.330670|INFO |CrossTalk | |Position Spread: setSpreadWidth: 0.5
2020-03-08 14:47:24.330670|INFO |CrossTalk | |Position Spread: setRegionWhisper: 2
2020-03-08 14:47:24.330670|INFO |CrossTalk | |Position Spread: setRegionOther: 0
2020-03-08 14:47:24.330670|INFO |CrossTalk | |ChannelMuter: enabled: true
2020-03-08 14:47:24.330670|INFO |CrossTalk | |init done
2020-03-08 14:47:24.330670|INFO |Plugins | |Loading plugin: volume_control_broesel_win64.dll
2020-03-08 14:47:24.331674|INFO |Plugins | |Api version is not compatible for plugin: C:\Users\chris\AppData\Roaming\TS3Client\plugins\volume_control_broesel_win64.dll
2020-03-08 14:47:24.412423|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2020-03-08 14:47:24.412423|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2020-03-08 14:47:24.430375|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.482237|INFO |Addon | |Not available for this platform.
2020-03-08 14:47:24.529254|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.580118|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.634603|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.682471|INFO | | |*** Time [BUILD_GUI]: 267
2020-03-08 14:47:24.699404|INFO | | |*** Time [SERVERVIEW]: 288
2020-03-08 14:47:24.703394|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.705076|INFO | | |*** Time [SERVERVIEWMANAGER]: 306
2020-03-08 14:47:24.758932|INFO | | |myts client id: ba614140-e28d-40bc-9e6b-ed3cc90b9324
2020-03-08 14:47:24.759952|INFO | | |*** Time [MAINWINDOW]: 696
2020-03-08 14:47:24.759952|INFO | | |*** Time [INIT]: 696
2020-03-08 14:47:24.765942|INFO |ClientUI | |Qt version: 5.12.3
2020-03-08 14:47:24.765942|INFO |ClientUI | |Using configuration location: C:\Users\chris\AppData\Roaming\TS3Client\settings.db
2020-03-08 14:47:24.768940|INFO |Addon | |Addon up to date.
2020-03-08 14:47:24.814351|INFO |Addon | |Addon up to date.
2020-03-08 14:47:25.259259|INFO |Bookmarks | |Collecting autoconnect bookmarks
2020-03-08 14:47:25.259259|INFO |ClientUI | |Last update check was: So Mrz 8 13:19:33 2020
2020-03-08 14:47:25.260253|INFO | | |Statistics report: Not yet, next report on Mi Apr 1 18:12:46 2020
2020-03-08 14:47:25.760314|INFO |Newsticker | |Newsticker next check: So Mrz 8 19:06:17 2020 GMT
2020-03-08 14:47:29.263991|INFO |ClientUI |1 |Connect to server: ts18.d11.ts-server.de
2020-03-08 14:47:29.264998|INFO |ClientUI |1 |Trying to resolve ts18.d11.ts-server.de
2020-03-08 14:47:29.274973|INFO |TSDNS | |SRV DNS resolve successful, “_tsdns._tcp.ts-server.de” =(h: phostyx.de p:41144), (h: d3.phostyx.de p:41144), (h: nbg12c.phostyx.de p:41144)
2020-03-08 14:47:29.331944|INFO |TSDNS | |SRV DNS resolve unsuccessful, “_ts3._udp.ts18.d11.ts-server.de” The resolved dns name produced no (usable) records
2020-03-08 14:47:29.336932|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “d11.ts-server.de” =(h: p:0)
2020-03-08 14:47:29.339923|INFO |TSDNS | |A/AAAA DNS resolve successful, “nbg12c.phostyx.de” =(h: p:0)
2020-03-08 14:47:29.384022|INFO |TSDNS | |A/AAAA DNS resolve successful, “phostyx.de” =(h: p:0)
2020-03-08 14:47:29.390005|INFO |TSDNS | |A/AAAA DNS resolve successful, “d3.phostyx.de” =(h: p:0)
2020-03-08 14:47:30.583433|INFO |TSDNS | |A/AAAA DNS resolve successful, “ts18.d11.ts-server.de” =(h: p:0)
2020-03-08 14:47:30.836920|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “ts-server.de” =(h: p:0)
2020-03-08 14:47:31.338646|INFO |TSDNS | |TSDNS queried unsuccessfully
2020-03-08 14:47:31.338646|INFO |TSDNS | |No TSDNS found
2020-03-08 14:47:31.390538|INFO |TSDNS | |TSDNS queried unsuccessfully
2020-03-08 14:47:32.838087|INFO |TSDNS | |TSDNS queried unsuccessfully
2020-03-08 14:47:32.838087|INFO |TSDNS | |No TSDNS found
2020-03-08 14:47:33.391477|INFO |TSDNS | |TSDNS queried unsuccessfully
2020-03-08 14:47:35.392108|INFO |TSDNS | |TSDNS queried unsuccessfully
2020-03-08 14:47:35.392108|INFO |TSDNS | |No TSDNS found
2020-03-08 14:47:35.392108|INFO |ClientUI |1 |Lookup finished: query= error=2
2020-03-08 14:47:35.393975|INFO |ClientUI |1 |Failed to resolve ts18.d11.ts-server.de
2020-03-08 14:47:44.998324|INFO |CapSoundSet | |Invalid captureDevice in Config File, (profile, captureDevice) = (StereoMix, Stereomix (Realtek(R) Audio))
2020-03-08 14:48:18.398135|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2020-03-08 14:48:18.398135|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2020-03-08 14:48:18.398135|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
2020-03-08 14:48:18.398135|DEVELOP |Windows Audio Session| |DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
2020-03-08 14:48:18.399132|DEVELOP |Windows Audio Session| |DeviceDeleteList::clear_queue - enter - DeviceDeleteList

I’m not sure, but I guess it’s

ts3client_2020-03-08__15_50_20.411911.log | successful via vpn
2020-03-08 14:50:25.554485|INFO |ClientUI |1 |Connect to server: ts18.d11.ts-server.de
2020-03-08 14:50:25.556138|INFO |ClientUI |1 |Trying to resolve ts18.d11.ts-server.de
2020-03-08 14:50:25.594074|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “ts-server.de” =(h: p:0)
2020-03-08 14:50:25.624896|INFO |TSDNS | |SRV DNS resolve successful, “_tsdns._tcp.ts-server.de” =(h: planet2.phostyx.de p:41144), (h: d3.phostyx.de p:41144), (h: nbg12c.phostyx.de p:41144)
2020-03-08 14:50:25.627888|INFO |TSDNS | |SRV DNS resolve unsuccessful, “_ts3._udp.ts18.d11.ts-server.de” The resolved dns name produced no (usable) records
2020-03-08 14:50:25.628812|INFO |TSDNS | |A/AAAA DNS resolve for possible TSDNS successful, “d11.ts-server.de” =(h: p:0)
2020-03-08 14:50:25.655199|INFO |TSDNS | |A/AAAA DNS resolve successful, “nbg12c.phostyx.de” =(h: p:0)
2020-03-08 14:50:25.656273|INFO |TSDNS | |A/AAAA DNS resolve successful, “planet2.phostyx.de” =(h: p:0)
2020-03-08 14:50:25.677505|INFO |TSDNS | |A/AAAA DNS resolve successful, “d3.phostyx.de” =(h: p:0)
2020-03-08 14:50:25.712689|INFO |TSDNS | |TSDNS found at and queried successfully. Result: (h: p:1227)
2020-03-08 14:50:25.723540|INFO |TSDNS | |TSDNS found at and queried successfully. Result: (h: p:1227)
2020-03-08 14:50:25.763919|INFO |TSDNS | |TSDNS found at and queried successfully. Result: (h: p:1227)
2020-03-08 14:50:25.764916|INFO |ClientUI |1 |Lookup finished: ip= port=1227 query=ts18.d11.ts-server.de error=0
2020-03-08 14:50:25.764916|INFO |ClientUI |1 |Resolve successful:
2020-03-08 14:50:25.764916|INFO |ClientUI |1 |Initiating connection:


I have set a temporary password: tssupport
I’m still not sure what’s wrong. Can’t connect without the VPN… :confused:

I restarted my router, the switch in between and flushed the local windows dns cache.

Ethernet-Adapter Ethernet:
Verbindungsspezifisches DNS-Suffix: fritz.box
Beschreibung. . . . . . . . . . . : Intel(R) Ethernet Connection (7) I219-V
DNS-Server . . . . . . . . . . . :

PP-Adapter Hide.ME IKEV2:
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Hide.ME IKEV2
DNS-Server . . . . . . . . . . . : fd00:6968:6564:3d1::1

These seam to be the ISPs Name Servers. dnsleaktest

IP Hostname ISP Country 83-169-186-163-isp.superkabel.de. Vodafone Kabel Deutschland Germany ip53a9baa3.static.kabel-deutschland.de. Vodafone Kabel Deutschland Germany None Vodafone Kabel Deutschland Germany

I tried it also with and as setting within the ethernet adapter konfiguration.
How did you find out i’m business customer?

So it may could be something like Vodafone using some sort of ECS with own protections against invalid dns records? Like some sort of extra security layer against dns poisoning or something like that?

nslookup -q=srv _ts3._udp.ts18.d11.ts-server.de
Server: fritz.box

Nicht autorisierende Antwort:
_ts3._udp.ts18.d11.ts-server.de canonical name = thevoid.phostyx.de

primary name server = ns2.phostyx.de
responsible mail addr = support.phostyx.de
serial = 2020010102
refresh = 10800 (3 hours)
retry = 1800 (30 mins)
expire = 604800 (7 days)
default TTL = 3600 (1 hour)

Yes, i got the regular version of the FRITZ!Box 6591 Cable.

I also use a pihole as local dns server with dnscrypt-proxy for the clients.
I only switched to default dns settings to take the pihole out as the source of error.

But it’s the same issue.

If I use the fritz.box dns with as primary and as secondary.

IP Hostname ISP Country res200.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res300.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res500.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res600.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res110.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res310.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res111.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany res211.fra.rrdns.pch.net. WoodyNet Frankfurt am Main, Germany

I get the same error.

nslookup -q=srv _ts3._udp.ts18.d11.ts-server.de
Server: fritz.box

Nicht autorisierende Antwort:
_ts3._udp.ts18.d11.ts-server.de canonical name = thevoid.phostyx.de

primary name server = ns2.phostyx.de
responsible mail addr = support.phostyx.de
serial = 2020010102
refresh = 10800 (3 hours)
retry = 1800 (30 mins)
expire = 604800 (7 days)
default TTL = 3600 (1 hour)

But i guess the result is maybe cached on fritz.box in this case. Maybe I should restart the router again.

I changed the DNSv4-Server
Bevorzugter DNSv4-Server:
Alternativer DNSv4-Server:

It’s now listed as cloudflare.

IP Hostname ISP Country None Cloudflare Düsseldorf, Germany

Same result with “nslookup -q=srv _ts3._udp.ts18.d11.ts-server.de” after “ipconfig /flushdns”
I only have a real IPv4 (not virtual).

and TeamSpeak
<17:15:21> Versuche den Hostnamen ts18.d11.ts-server.de aufzulösen
<17:15:27> Hostname ‘ts18.d11.ts-server.de’ konnte nicht aufgelöst werden

Hey guys, did u find any solution yet? I have exactly the same problem for a friends TS3 “teejay.phostyx.de

Would be great to here ur advice to fix this. also using FritzBox 6591

Before i changed the FritzBox 4 days ago it was working, needed to change it due to change of 400 to 1Gbit

Hallo 1dlesniper,

die Records vom Hoster waren/sind nicht richtig gesetzt.

Die Vermutung von FakE war, dass der Hoster noch alte DNS Einträge gesetzt hat, die er noch nicht gelöscht hat.

Da der Hoster seine eigenen Namensserver zur Auflösung verwendet, ist das sehr wahrscheinlich das Problem bei mir gewesen:

Domain Typ TTL Antwort
phostyx.de. NS 3600 ns2.nbg12.phostyx.de.
phostyx.de. NS 3600 ns2.phobyx.de.
phostyx.de. NS 3600 ns3.phostyx.de.
phostyx.de. NS 3600 ns.phostyx.de.

Zudem war die Gewichtung zu der Zeit seltsam verteilt.

$> nslookup -q=srv _tsdns._tcp.ts-server.de

Nicht autorisierende Antwort:
_tsdns._tcp.ts-server.de SRV service location:
priority = 0
weight = 3
port = 41144
svr hostname = planet2.phostyx.de
_tsdns._tcp.ts-server.de SRV service location:
priority = 0
weight = 5
port = 41144
svr hostname = phostyx.de
_tsdns._tcp.ts-server.de SRV service location:
priority = 1
weight = 3
port = 41144
svr hostname = d3.phostyx.de
_tsdns._tcp.ts-server.de SRV service location:
priority = 1
weight = 3
port = 41144
svr hostname = d11.phostyx.de
_tsdns._tcp.ts-server.de SRV service location:
priority = 1
weight = 5
port = 41144
svr hostname = d20.phostyx.de
_tsdns._tcp.ts-server.de SRV service location:
priority = 2
weight = 5
port = 41144
svr hostname = nbg12c.phostyx.de

Viele der Anfragen liefen also über:

svr hostname = phostyx.de
svr hostname = d20.phostyx.de
svr hostname = nbg12c.phostyx.de
Diese Routen waren damals richtig.

Die anderen DNS Anfragen liefen jedoch über:

svr hostname = planet2.phostyx.de
svr hostname = d3.phostyx.de
svr hostname = d11.phostyx.de
Diese Routen waren hingegen falsch:

Mit anderen Worten hätte man den TeamSpeak Server Provider mal informieren müssen, dass seine DNS Einträge unbedingt mal aufgeräumt werden sollten. Ich hatte es zwar an einem der TS Admins weitergegeben, aber letztendlich hat keiner sich drum gekümmert und den Hoster/Provider informiert.

**Die Lösungsempfehlung von Fake war damals: **

Der Provider muss den falschen Record _ts3._udp.ts18.d11.ts-server.de korrigieren.
SRV DNS resolve unsuccessful, “_ts3._udp.ts18.d11.ts-server.de”

SRV Records dürfen nur auf A(AAA) Records verweisen, um mit TeamSpeak zu funktionieren.

Falls du für den TS Geld zahlst wär es also sinnvoll einen entsprechenden Support Call aufzumachen.

Servus @Chris180

danke dir für deine schnelle Rückmeldung. Ist nicht mein TS und kenne auch den Owner nicht, ist nur ein TS auf dem Kumpels und ich uns öters treffen, nur funkt der jetzt für mich nicht mehr seit der neuen fritzbox aber für meine Freunde nachwievor ohne Probleme. Da er für meine Freunde geht und aber auch von meinem Handy aus über das gleiche Netzwerk (mit ausgeschalteten mobilen Daten) geht, muss das Problem irgendwo meinerseits Liegen bzw. die Fritzbox händelt LAN und WLAN Anschlüsse anders.

Sers 1dlesniper,

Als Hotfix kann ich dir empfehlen: Join einfach über die IP anstelle des DNS-Namen.
Die kann dir einer der Kumpels, bei dem es funktioniert, sicherlich geben und ist in der Regel auch statisch (zumindest bei kommerziellen Hostern).

Bei DNS kommt nämlich noch das DNS-Caching hinzu.
Wenn du wirklich Testen möchtest, ob es über Handy im WLAN geht, müsstest du es ohne Mobile Daten (nur WLAN) probieren, nachdem der DNS-Cache geleert wurde. Dasselbe betrifft auch den PC und ggf. die Fritz Box, wenn du dort den DNS veränderst.

Per Default weist die Fritz box sich selbst anderen Geräten als Vorschlag für den DNS-Server zu.
Weiß die Fritz box die IP nicht fragt sie den nächsthöheren Server (meistens der vom ISP), solange bis ein DNS Server die Antwort kennt. In Fall einer .de “Top Level” Domain, also spätestens die root Server der DENIC.

Wenn du auf einen Gigabit Vertrag gewechselt bist, kann es durchaus sein, dass du dadurch in ein anderes VLAN oder Subnetz vom Internet Service Provider gerutscht bist und die Anfrage auf einen anderen DNS Server geht, welcher laienhaft gesprochen die “schlechte” DNS Antwort hat. Gigabit Anschlüsse sind nämlich in der Regel auf DOCSIS 3.1 (fängt ggf. schon bei 500 MBit Verträgen an) während 400k sicherlich noch auf DOCSIS 3.0 lief (die Fritz Box 6590 kann auch kein DOCSIS 3.1)

Ich hoffe das hilft dir bereits weiter.

LG Christian

FAST gute Analyse, aber:
Die DNS-Records sind vollständig korrekt (und alle routen auch?!).
Der ts3.udp… - Record existiert überhaupt nicht und rennt in ein Wildcard-Record (eben ein CNAME), der wohl gar nicht für TS gedacht ist. Ist auch logisch, da ts18.d11 kein einzelner server ist (ts18 ist eine ganze Gruppe von Servern, nicht nur mit unterschiedlichen Ports sondern auch IPs, es macht also überhaupt keinen SInn hier einen ts3.udp-record zu haben; und d11 ist ein Fallback für einen TSDNS-Server - TS löst das automatisch per normalem DNS auf wenn alles andere fehlschlägt - nützt hier nur nix, denn:)

Das Problem ist die aktuelle Firmware der Fritz.box FÜR GLASFASERANSCHLÜSSE von Vodafone/Kabel/Unity) seit März, die die Antwort der TSDNS aus unbekanntem Grund einfach nicht “durchlässt”, das wurde schon mehrfach gecheckt. Alle anderen (Kupfer, andere Router oder andere Anbieter) kommen auch wunderbar durch.
Da beisst man aber leider bisher bei Fritz und Vodafone auf Granit…

Sehr unschön…
(PS: Ich bin der Typ der des öfteren die tcpdumps dazu analysiert hat. Leider sind ausgiebig welche auf TSDNS-Serverseite da, aber kaum auf Seite hinter der Fritbox. Kann mir bitte vllt. jemand der dieses Problem hat den ein oder anderen (z.B. Wirekshark-) Mischnitt für TCP Port 41144 schicken bitte?)

Die Info ist recht wertvoll, danke! Auch bestätigt das nochmals, dass das Problem an der Fritz.Box liegt.
Da muss dann vermutlich irgendeine stateful inspection für die LAN-Seite laufen, die vllt. allergisch auf IP-Adressen reagiert (mehr kommt da beim TSDNS nämlich nicht, einfach nur IP und Port als String, und dann TCP close).
Weitere Vermutung: Da der TS-Client preisgibt ob er IPV6-Fähig ist schickt er u.a. bei der Anfrage bestimmte Kombinationen die Newline-Characters enthalten - die TCP-Verbindung sieht also zeilenbarsiert aus statt binär. Die Antwort enthält aber KEINE Newline-Characters (wenn sie es tut versteht der TS-Client sie allerdings als “not found”-Antwort, wurde schon ausprobiert). Es könnte also einfach nur ein Bug irgendeines Filters der FritzBoxsein, der die letzte “Zeile” aus Versehen bei einem TCP-Close “wegfrisst”, da sie scheinbar ja nicht abgeschlossen ist. Halte ich aber für unwahrscheinlicher, denn auch in Binärstreams sind CR und LF-Werte ja durchaus mal drin - dann würde aber viel mehr “Mist” auch mit anderer Software passieren. (Es sei denn, es liegt am Port 41144, dem hier irgendeine andere Bedeutung beigemessen wird)

Hallo Rizzo,
ich kann das gerne machen sobald das Problem bei mir wieder auftritt.
Die letzten Tage funktionierte die Verbindung zum Server problemlos.

Ich bin wie gesagt nicht so häufig in dem TS, erst jetzt durch Among Us und Urlaub hat das wieder etwas fahrt aufgenommen.

Ich habe heute Nacht auch mal ein Ticket bei pHOSTxy aufgemacht und folgende Antwort erhalten.

Das deckt sich ja quasi mit deiner Aussage.

Jetzt wo ich das mit der Fritz!OS Version lese…

… es kann natürlich gut sein, dass die Ursache schon behoben ist.

Zu dem Zeitpunkt des Fehlers hatte ich die “freie” 6591 AVM Fritz!Box als primären Router.
Damals noch mit Fritz!OS 161.07.13.

Wegen permanenten Telefonie Störungen im Festnetz hat mich Vodafon regelrecht auf die gebrandete “HomeBox” Variante der 9591 genötigt. Gewechselt bin ich am 02.04.2020 ca. gegen 20:56 Uhr. Zu dem Zeitpunkt hatte die HomeBox noch 07.04 (hängt ja immer hinterher).

Ich hatte nach dem Wechsel der Boxen explizit bei Vodafon angefragt für >07.10 und habe seit mindestens dem 18.08. auch auf der HomeBox Fritz!OS 161.07.13 provisioniert bekommen.
→ Da die kdg Versionen nicht nur später veröffentlich werden, sondern auch inhaltlich nochmal abweichend zu dem regulären AVM Release sind, wäre es durchaus möglich, dass dadurch die Probleme beseitigt wurden. Das würde aber nur aufgehen, wenn 1dlesniper noch auf Fritz!OS 07.04 ist.

Zumindest hat sich AVM im Rahmen von 07.21 mit den DNS-Funktionalitäten der FritzBox beschäftigt und die Möglichkeit besteht, dass es einige Korrekturen bereits ins KDG Release der 07.13 geschafft haben, welche aber im freien 07.13 nicht enthalten sind.

Auszug Changelog FRITZ!OS 7.21

  • NEU Unterstützung verschlüsselter Auflösung von Domain-Namen zu IP-Adressen (DNS over TLS)
  • Verbesserung Unterstützung mehrerer DNS-Anfragen über eine einzige TCP-Verbindung
  • Verbesserung Im Rahmen der verschlüsselten Namensauflösung (DNS over TLS, DoT) wird SNI (Server Name Indication) unterstützt.

Zudem müsste ja auch für die Vodafon Boxen das FRITZ!OS 07.21 im internen Test sein und bald in den Rollout gehen.

**Quellen: **
Fritz!OS Changelog für Fritz!Box 6591 Cable

Also die FritzBox ist auf V 07.13, ist auch eine gebrandete die von Vodafone bereitgestellt wurde.
Habe das jetzt nochmals bestätigt, über WLAN funkt die Verbindung zum TS Srv in 100% der Fälle, bei einer LAN Verbindung (egal welcher PC/Laptop) garnicht, wobei ich gestern einmal draufkam, danach aber nie wieder.