Failed to bind port 9987

Windows 11 64. I have installed the server software. I have tried running as adminstrator. However the app will not launch. The log has this error
2022-04-24 05:04:57.363592|ERROR |VirtualServerBase|1 |bind failed on 0.0.0.0:9987, :::9987
2022-04-24 05:04:57.363592|INFO |VirtualServerBase|1 |stopped
I have disabled all firewalls to try. Does not work. Can anyone help me? Thanks.

Check that you don’t have an instance already started or a software that is taking one of the ports used by teamspeak. (9987, 10011, 30033)

Thanks for your reply. No other instance running. Also have shut down other software. Still won’t launch

Try to delete the server and reinstall the package again.

Have done that about 5 times. Same error about port 9987. Have added the port to the router. Have added teamspeak to firewall private so firewall will not block it

Usually the message appears when something on the machine where server was started already does use the port. Check whatever this port is using already.

In second case it was blocked by a firewall or antivirus.

3 Likes

Thanks for your reply. How do I check what is using the port

With the netstat -a command

2 Likes

Thanks everyone for your help. I give up. The port 9987 did not come up on the list with the command provided. I turned off my firewall and virus protection and still getting the same error.

You could try if server starts on another port.

Thse are the commands needed for the Query Interface over Telnet/Putty/SSH

login serveradmin yourpassword
use 1 -virtual
serveredit virtualserver_port=9988
use 0
serverstart sid=1

1 Like
twitch instagram twitter facebook