Fatal Error - Connection refused, Putty


A few days ago I bought a Teamspeak3 server from you.
Its ran on a hardware notebook with Linux.
Now, my main PC has Windows and I googled, that I can access Server Query or console through an app called PuTTY.
I tried it, tried many combinations of my network TS3 IP and worldwide IP, also many kinds of ports, because mine didnt work.
After every attempt, trying to log into putty i got an error called “Network error : Connection refused”
After googling it, I read, that it can be because the TS3 server host didnt give me access.
So im asking you, how do I fix it?
I bought Teamspeak officially, from you, because I wanted the console feature no toher host would give me.
Thanks for you answer.


Are you trying to login via SSH or telnet?
Server Query access is only via telnet.
If you are hosting the server on a notebook, be sure the network and the firewall are well configured.

Btw, I don’t understand where your server is. Teamspeak sells licenses to run the servers, so you bought that and installed a server on your notebook or you rented a server from an authorized hosting? In the second case it’s not guaranteed that you will have serverquery access. It depends on the hosting policies. Maybe ask them.

Please be more specific in your question so people can help you

Already fixed, but thanks.
I had to open SSH, not telnet.

1 Like

ok, you’re welcome

Ps. We are not selling any server.


xd, what I were saying

1 Like