First Run Create Table Error Using MariaDB Plugin and Configuration / FreeBSD

I am receiving the following error when starting a freshly installed TeamSpeak 3 server, using the MariaDB plugin. Initial TS3 server database created, database user created and granted all privileges to TS3 database. Tested with both MySQL 8.0 and MariaDB 10.5, same result.

|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.13.3 (2020-12-16 14:17:05)
|INFO    |ServerLibPriv |   |SystemInformation: FreeBSD 13.0-RELEASE-p1 FreeBSD 13.0-RELEASE-p1 #0: Wed May 26 22:15:09 UTC 2021     [email protected]:/usr/obj/usr/src/amd64.amd64/sys/GENERIC amd64 Binary: 64bit
|INFO    |DatabaseQuery |   |dbPlugin name:    MariaDB plugin, version 3, (c)TeamSpeak Systems GmbH
|INFO    |DatabaseQuery |   |dbPlugin version: 2
|ERROR   |DatabaseQuery |   |db_exec() CREATE TABLE channel_properties (  server_id integer unsigned,  id     error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'NOT NULL,  channel_parent_id  integer unsigned,  server_id          integer u...' at line 1
|CRITICAL|SQL           |   |db_CreateTables() unable to create tables

Note that I am currently running a production TS3 server successfully with a MariaDB database. Previously this initial creation of the tables worked as expected.

Configuring for and using SQLite works flawlessly and the TS3 server launches without error on first run.

Any help or suggestions would be appreciated.

First, your server is outdated… Please try to update your server.

Make sure you extracted all files. Sometimes sql files are not replaced from user while extraction and then such error could appears.

Have you made any changes in the create_tables.sql ?

1 Like

I updated the server binary to latest version 3.13.6, including all .sql files, plugin files etc. same results.

No I didn’t change it, create_tables.sql is unmodified. Turns out there is nothing wrong with the syntax of create_tables.sql. I can manually import it successfully without error using mysql -u teamspeak -p’password’ teamspeak < create_mariadb/create_tables.sql

Can you show me your ts3server.ini ?

ts3server.ini

dbplugin=ts3db_mariadb
dbpluginparameter=mysql.ini
logappend=1

mysql.ini

[config]
#port=3306
socket=/var/run/mysql/mysql.sock
username=teamspeak
password='testing'
database=teamspeak
dbsqlcreatepath=create_mariadb/
twitch instagram twitter facebook