Focusrite Scarlett crackling audio

Hello, I use a Focusrite Scarlett 2i2 gen 2. If it’s on 2 channels, 24bit 48k hz in windows sound properties, the sound in TeamSpeak start to crackle and chop up. If i set it to 1 channel, 16 bit 48k hz it seems to be fine. However, after some time (sometimes half an hour, sometimes half a day) the microphone starts to crackle and chop up again.

Following this guide makes no difference: https://support.focusrite.com/hc/en-gb/articles/360013759200-I-m-getting-clicks-pops-or-distortion-using-Discord-Zoom-Teamspeak-or-another-VoIP-app-on-Windows

I can only assume this is a TeamSpeak problem, since if I chose to listen to the microphone in Windows, everything sounds fine, but if I do it in TS5, it has the issues. It’s super annoying because I don’t know when it happens either, unless my mates tell me my microphone went bad again.

Have you tried changing this?

Hi,

I have the same problem with Scarlett Solo 3rd Gen. The solution is to change the Capture Mode to direct sound not the windows one.

But with this option, another problem appears: You’ll get some delay after some time.
After 4hours in Teamspeak, the delay is over 1second in my case. Restarting the Teamspeak Client resets the delay.
There are two older threads:
https://forum.teamspeak.com/threads/75724-Voice-delay-after-few-hours-connected/page3
https://forum.teamspeak.com/threads/133808-Delay-in-my-voice-after-a-few-hours-connected

I’m not sure why Teamspeak is not able to handle this problem until today for teamspeak 3 or 5.

The Capture Mode option is not present in TeamSpeak 5 :confused:

I’m currently testing this solution: https://www.youtube.com/watch?v=71HrZfR_Fro
Even if it works it seems like a hacky workaround, and I wouldn’t want to rely on it.

Since “Listen to device” in Windows works fine, there has to be a way for TeamSpeak to record audio properly.

For the software in the video you have posted, it helps for me to deactivate the echo cancellation and automatic gain control.

I also missing the capture mode in TS5… how is it possible, that there are many threads with the same topic and nothing happened to solve this problem in TS3 or 5? My linked Threads are from 2012.

Especially Teamspeak, which is popular for the good audio quality should support 24bit/48khz from Audio Interfaces or Mixers without any problems. In other Tools like Audacity or OBS there are no problems.

Here is a workaround for scarlett 2i2 2nd gen and scarlett solo. Not tested with 3rd gen devices.

  1. Deinstall the newest focusrite driver from windows
  2. Install the old 3.2.2 driver from Focusrite. I have uploaded it here because it’s not available anymore on the focusrite site:
    https://1drv.ms/u/s!ArSPT-qNarAnpBxaud86IccfPuTH

I had some focusrite devices over the last four years and come across the same issues that you mentioned here. Searched the whole web for a solution and contacted the Support many times. If there is another way pls let me know.
Anyway I hope it helps someone.

Edit: Use always direct sound in Teamspeak, like noticed in the posts above!

Meeshaw

Yeah I’m gonna go ahead and not install drivers unless they are from the official site, and if i need direct sound it wouldn’t work anyway because it’s not an option on TS5 :stuck_out_tongue:

I found that setting audiodg.exe priority to “High” and CPU Affinity to CPU 2 like in the video worked. However doing so resets every time the computer restarts.

So I created a powershell script to do it;

$process = Get-Process audiodg
$process.ProcessorAffinity = 4
$process.PriorityClass = "High"

Which I can then run on every logon using Task Scheduler. If anyone else needs to set it up;

  • Under General, check the box “Run with highest privileges”
  • Under Triggers, add a trigger that runs at logon of any user, with a 30 second delay
  • Under Actions, start a program “powershell”, with the path to the script as argument, e.g. “C:/path/to/script.ps1”

This shouldn’t be a thing I have to do in a voicechat program though. Please fix.

Edit: Had to add a 30 second delay to the trigger, as it seem to have run before audiodg.exe started.

Well, but a workaround is not a good solution - especially, if the audio interface doesn’t has any problems with other software like Audacity, Streamlabs and other Software.

So 2 questions to the teamspeak team:

  1. Why the direct sound option in TS3 has delay for years without fixing it
  2. Why this option was removed in TS5?
twitch instagram twitter facebook