Help debugging Windows server install

I’m stumped looking for help. I haven’t used teamspeak in a couple of years. I have the server software on my main computer and it has worked fine in the past. I Downloaded the latest server to my Windows 10 PC, Placed it in the subdirectory of the old version. When I run it, the Terms and Conditions window appears, I accept, then the program goes away completely. I’ve turned off firewalls, no effect. Suggestions on further debugging would be appreciated

You got a log for us?


Don’t understand your question…

i think he meant log :wink:

Yes. Tablet made lot out of it.


Ah, ok. My noobness is showing, but I couldn’t find a log in the TS directory or the root directory. What will the filename be?

The folder is called logs and the file ts3server_DATEOFSERVERSTART

1 Like

No logs directory in the current TS3 Directory. There was one in the old renamed ts directory but its last entry was “the default license has expired. Please use the latest server version.”…

FWIW, I went to a different computer that I had the server running on in the past and got the same response

This tells us nothing. We need a log or error or anything. :smiley:


I assume that if the TS Server initiated properly it would produce a log right? What does it mean that it is not?

If there is nothing in the log folder then the process did crash.
Check your operation system if there is an error report.

There must be at least the accept_license_error....log file when the agreement appears and it was rejected.

Or server logs when the agreement was accepted.


Must leave for a bit will get back on this later. There is no log directory. Should I make one? or shouldn’t the program generate one at some point. Will check the system logs when I return

This will be generated when the process did not crash directly on start.


Went through the Windows Event Viewer didn’t see anything that corresponded to the time stamp of activating teamspeak…