I cant connect to a server with windscribe VPN

I get an error when i try to connect to a server

That’s a hella lot of information (pun intended)!

OK, sarcasm mode off, lets face the problem.

First and foremost, what’s the error you’re getting?
Second, it might be helpful to know what server you’re trying to connect.
Third, are you sure that Server Admins haven’t blocked most common VPN IPs? That happens a lot from what I remember.

Some time ago (~3-4 years) I tried to use VPN with TeamSpeak, but it haven’t worked, because of not supporting P2P. Supposedly this VPN supports P2P, but if that’s true, I don’t know.

Remember, more info you give us, more likely we can help you. Simply stating ”cant connect error” is a little bit to little.

There could be many reasons why you’re unable to connect to a server or it disconnects randomy, these may include but are not limited to:

  1. Software on your computer preventing Windscribe from connecting. This may include anti-virus, anti-malware or personal firewalls.
  2. Network that you’re on is blocking or interfering with VPN connections.

But anyway the Problem to connect with a VPN to a TeamSpeak Server has nothing to do with the Product TeamSpeak itself. There is no Support from TeamSpeak.

twitch instagram twitter facebook