I can't set an avatar on my client

Hello,

I’m having this particular problem from more than a year, basically I can’t set an avatar, regardless of where I am connected, I’m usually on my server, where I am the main admin since I’m the owner.
I even tried some images that respected all of the criteria (dimensions and size in kb).
Cleared cache (via the options in the program and in appdata).
Tried to reinstall the application.
Last of all but didn’t do it for teamspeak, reinstalled Windows 10 as a clean install on my machine.

I really don’t have any other answers.
Any other suggestion is appreciated.

Thanks in advance.

Leonardo.

did you look at the client log?

is there an error message somewhere?

thanks for asnwering back, this is what I get:

10/01/2021 15:31:27 UIHelpers Info Supported image formats: *.bmp *.gif *.jpeg *.jpg *.pbm *.pgm *.png *.ppm *.svg *.svgz *.xbm *.xpm

10/01/2021 15:31:35 ClientUI Info Avatar file size check: 1 200000

10/01/2021 15:31:35 ClientUI Warning Failed to remove temp avatar copy

I tried to use a 200x200 .jpg avatar I made with microsoft paint, just to test.

1 Like

sounds like some permission issue, writing right maybe
at first this would be my tip

Here is a list of possible issues related to the error

Client:

Your cache is broken (please clear the client cache)
The file you like to upload can not be read due permissions in cache folder.

Machine where server is running on:

The a file with exact the same name already does exist on server and can not be deleted and replaced with the new one. Could be broken file or missing permissions to this are not given in the operation system.

Or file can not be created in the files folder.

2 Likes

I tried to upload an Image as avatar (jpg 14 KB) on some servers but it never works. In formerly used ts client the same jpg works on this pc as avatar.
In server log is no error mentioned when i upload my avatar, but in my ts client (3.5.6) the client protocol (shown if you click strg-L) a warning appears:

15.01.2021 13:47:10 PktHandler Devel Puzzle solve time: 11
15.01.2021 13:47:10 ClientUI Info Connect status: Connected
15.01.2021 13:47:10 ClientUI Info Connect status: Establishing connection
15.01.2021 13:47:10 ClientUI Info Connect status: Connection established
15.01.2021 13:47:18 UIHelpers Info Supported image formats: *.bmp *.gif *.jpeg *.jpg *.pbm *.pgm *.png *.ppm *.svg *.svgz *.xbm *.xpm
15.01.2021 13:47:25 ClientUI Info Avatar file size check: 1 200000
15.01.2021 13:47:25 ClientUI Warning Failed to remove temp avatar copy

Any idea for solving this problem?

I see a suggestion in other topic, but can you explain what to do exactly?

I’ve cleared it in TS3 -> Tools -> Options -> Security and there “Clear Cache” --> done and also reinstall ts3 but doesn’t help

I can see the jpg file in windows explorer in normal directory. Also tried to start ts as administrator … same result: no avatar uploaded

In the old forum i found an hint from user Andibyts:

When I go to “C:\Users\USERNAME\AppData\Local\Temp” and delete an folder called “avatar” I’m able to change my avatars till i log in to my Pc again.
But in this folder is just the avatar of my Microsoft-Account, nothing from teamspeak.

This work as described. Delete folder, upload avatar works at all servers, restart PC, only remove avatar is possible but upload again don’t.

1 Like

Sorry if I disappeared, I tried all of the suggestions above, nothing worked for me.
Just tell me what else I could try.

I have the same problem
But i guess once you set the avatar it should stay on the server or doesn’t it?

the avatar file is uploaded to server. At my server avatar files stored in server folder /var/ts3server/files/virtualserver_1/internal.
You can choose at every server a different avatar.

Problem is that I don’t have access to servers local files, I just have a rental program, but the problem is on my client, still didn’t find an answer to it.

merged and moved by moderator

Hi! I use a translator, so do not judge strictly for the construction of the sentence. In my TS3 there is a problem which already… a lot of time, perhaps more than a year has passed. I can’t install an avatar, at the same time, I don’t observe errors and I can’t do it on any server (although I have the rights to do it) while I see other people’s avatars. I’ve already tried reinstalling the application, clearing the cache, even reinstalling windows, but it didn’t lead to anything

I also attach messages from the log

26.07.2022 08:58:40 ClientUI Info Avatar file size check: 1 200000
26.07.2022 08:58:40 ClientUI Warning Failed to remove temp avatar copy

Have you tried to use other images as your avatar and if yes what does it say?

I tried with a png file, nothing helped, I use different images of different sizes, once upon a time, the same images were installed on avatars

What if you try to start your Client as an admin and then set an avatar?

if that does not work I found another solution:
It seems like the client cannot delete the cached avatar file in the following folder :

Code:

Users[USERNAME]\AppData\Local\Temp

Manually deleting the file named :

Code:
avatar

will enable you to change your avatar again.
(note this is a hidden system folder)

The same user also wrote: But also went to C:\Documents and Settings[USER]\Application Data\TS3Client\cache (XP directories) and deleted the files there which allowed me to add an avatar, also involves going into hidden folders. That said, that is the install directory so just find where you installed TS3 and open the cache folder, delete and you should be away

[original post]
Resolved Failed to remove existing loca/templ avatar copy - TeamSpeak

1 Like
twitch instagram twitter facebook