I lost all my data (solved)

I got a complete wipe of my Bookmarks (50+) and all my identities when I updated to 3.5.1. My sync was on and I got the same pop up window coming up again and again again interrupting everything I did (I am a hardcore gamer btw) every couple of minutes which was annoying so I turned off sync completely (the pop up was something like: “There is an unexpected error with synchronization, it’s not available at the moment”). When I turned it back on (logged in again as me) and restarted the TS 3, everything was gone. Now I can’t even open bookmarks (I can but everything is blank and grey) even tho I bookmarked again my TS server. It’s so annoying to lose progress and such a large collection of all TS 3 gaming servers I used for different games and all my permissions on all my identities. And it’s still bugged. I even tried uninstalling it and installing some of the older versions I have on my PC (I don’t have a version I had before the update) but nope, everything was the very same.
What the hell happened? And can you do a backup restore from my account? The option to “sync all automatically” was on all the time, and as I said, I had like 50+ bookmarks all sorted out and like 6-7 different identities.
That happened on 25.03.2020. around 9PM.

1 Like

When you see that the area for synced times is Grey then you are not logged in or Synchronization is disabled.

Make sure that you are logged in into the right account and check your logs for errors when you think you are logged in.


I was logged in for like a year, it was always saying in the options that “you are logged in as …” but I had only that problem with sync after the actual update (this latest one 3.5.1) where I got a spammy pop up message saying there is some problem with a sync. Then I just clicked to log out, and I uncheck the box for sync, exited TS, checked the box to sync again and logged in again and had a complete account wipe. Which is ridiculous. I also had that box for “automatic” sync all the time and all of my bookmarks and profiles were in the section “synchronized” not the “local”. Like seriously? Why do I even bother when after some next patch I will get another profile wipe? I guess I should just export everything from time to time. FFS

Here is a proof of the bug. Any more bright ideas?

That TS server is the one I re-added because I needed it for the game (World of Tanks).

What you showed is not a bug. It shows that your account is not ready to synchronize anything.

Please click on both icons. One tells you that your account encryption is not setup (you need to enter a recovery key). This happens after a password reset.

The other icon tells you that there is another problem. You will see it in the client log.

The bookmarks Dialog has these 3 dots.

Click and hold these and then move your mouse up a bit and there you see local stored bookmarks.


When I pull the dots it’s also empty. Don’t painting my eyes I already told you that I know the difference between local and sync.
This is the log:

21.04.20. 13:07:19 Info TeamSpeak Client 3.5.2 (2020-04-02 07:35:52)
21.04.20. 13:07:19 Info SystemInformation: Windows 10 (17134) x64 (AMD or Intel) Binary: 64bit
21.04.20. 13:07:19 Info Using hardware aes
21.04.20. 13:07:19 Direct Sound Debug setting timer resolution to 1ms -
21.04.20. 13:07:19 ClientUI Info OpenGL Info: LibGLES, Vendor: Google Inc., Renderer: ANGLE (NVIDIA GeForce GTX 1060 6GB Direct3D11 vs_5_0 ps_5_0), Version: OpenGL ES 2.0 (ANGLE
21.04.20. 13:07:19 Addons Info Checking for addon updates…
21.04.20. 13:07:19 Plugins Info Loading plugin: teamspeak_control_plugin_win64.dll
21.04.20. 13:07:19 ControlPlugin Info Control Plugin started, accepting connections
21.04.20. 13:07:19 Plugins Info Loading plugin: clientquery_plugin_win64.dll
21.04.20. 13:07:19 Query Info listening on
21.04.20. 13:07:19 Plugins Info Loading plugin: gamepad_joystick_win64.dll
21.04.20. 13:07:20 Gamepad Plugin Info Found client raw input wnd proc
21.04.20. 13:07:20 Gamepad Plugin Info Cleared device list
21.04.20. 13:07:20 Gamepad Plugin Info Found device \?\HID#VID_046D&PID_C52B&MI_02&COL03#7&1836DE4A&0&0002#{4D1E55B2-F16F-11CF-88CB-001111000030}
21.04.20. 13:07:20 Addon Info Addon up to date.
21.04.20. 13:07:20 Windows Audio Session Devel DeviceDeleteList::wait_for_deletes - enter - DeviceDeleteList
21.04.20. 13:07:20 Windows Audio Session Devel DeviceDeleteList::wait_for_deletes - leave - DeviceDeleteList
21.04.20. 13:07:20 Info *** Time [BUILD_GUI]: 228
21.04.20. 13:07:20 Info *** Time [SERVERVIEW]: 251
21.04.20. 13:07:20 Info *** Time [SERVERVIEWMANAGER]: 320
21.04.20. 13:07:20 Info *** Time [MAINWINDOW]: 889
21.04.20. 13:07:20 Info *** Time [INIT]: 889
21.04.20. 13:07:20 ClientUI Info Qt version: 5.12.3
21.04.20. 13:07:20 ClientUI Info Using configuration location: C:\Users\Dudu\AppData\Roaming\TS3Client\settings.db
21.04.20. 13:07:21 Bookmarks Info Collecting autoconnect bookmarks
21.04.20. 13:07:21 ClientUI Info Last update check was: Tue Apr 21 01:51:06 2020
21.04.20. 13:07:21 Info Statistics report: User previously denied participation
21.04.20. 13:07:21 Newsticker Info Newsticker next check: Tue Apr 21 23:51:06 2020 GMT
21.04.20. 13:07:22 SyncImpl Error Failed to force sync
21.04.20. 13:07:27 SyncImpl Error Failed to resume syncing: not_initialized
21.04.20. 13:07:29 SyncImpl Error Failed to force sync
21.04.20. 13:07:55 SyncImpl Error Failed to resume syncing: not_initialized

But there is nothing about that time when the actual wipe happened. So when you lose 50+ of your bookmarks it’s a feature and not a bug? Great support.

P.S. I don’t have a recovery key.

We see your account and there are the mentioned items stored.
And we see that you did reset your password the mentioned day and time (in that case you must own your recovery key!).

Following is now the case:


You did reset your password and logged out from client manually this is why you have no times and can not sync any longer.


Your account encryption was updated when you did reset your password. Now the client can not encrypt your account any longer and can not sync because of that reason.

It is now required to enter your recovery key and only then you get the items back.
OR you choose Fallback and start with a fresh encryption in case you do not have any.
You can do that by clicking the Blue icon with the shape of a Square and exclamation mark in it.

We can not restore any item in case you do not have your recovery key stored.
This is 1. why we tell you that you need to store it somewhere and 2. the website makes you to read and check that you own the recovery key :confused:

1 Like

It’s the key you get when you logged in for the first time with any client into your account.
A big dialog telling you that you need it to recover your data in such case and telling you that you need to write it down/save it somewhere.


You did reset your password (not just changed it) and this is why you have to use it now or reset the account as described.

1 Like

Just to clarify on the importance of the recovery key. The only way as a company we can store your data and NOT have access to it is by having a recovery key that ONLY YOU can access. The reason it’s done in this way is for security and encryption. Your privacy and data is important to you, and we like to ensure it remains that way.

When it comes to your recovery key it is vital you keep hold of it hence why we send you this notification:


It is so important because we do not have access to it, you are the only person with this key. We have no way to get access to this key and therefore no access to your personal data, settings, bookmarks or configuration at all; it is altogether a much more secure system, the way it should be.

If you want to change your password on our system at any time that’s fine, nothing will have to be changed. But if you perform a password reset (because you lost your password), as stated on the message above, you will need to use the recovery key (because your encryption changed) to then recover your data.

I’m not going to fully explain the security and encryption process in great detail, but easiest way to think of it is you have 2 house keys:

  • your password
  • your recovery key

If you lose your main key (password) you have a backup key (recovery). It wouldn’t be a very secure system if when you lost your house key, you asked the person who sold you the house to let you in because they kept a spare key… just in case…

So look after your recovery key :wink:

I’m glad it’s all resolved though.


In light of the amount of messages I’ve received about this thread, I just want to bring to everyone’s attention something I wrote as while back, as well as the forum rules/etiquette which can be found here: FAQ - TeamSpeak

Special emphasis should be placed on the last line:

Keep the language, links and images safe for family and friends.

Lots of people, young and old use these forums. You can all talk without swearing, being antagonistic or being rude to members of staff and regular forum users.