Input Device crashing

Hello,
when using TeamSpeak3 (Version 3.5.6) on an MX Linux (Debian 10 - Kernel 5.10.0-5mx-amd64) machine. My USB Microphone stops working after a few seconds to minutes. If i am currently speaking the blue transmitting icon is also stuck but nothing getting transmitted. This issue can only temporarily be resolved by restarting TeamSpeak or changing to another audio input device. No other application has this problem, but when the microphone “crashes” like this it can’t be used by other applications as well until TeamSpeak is closed. Below you can find the client log:

10.10.21 18:35:49 Info TeamSpeak Client 3.5.6 (2020-11-25 13:53:42)
10.10.21 18:35:49 Info SystemInformation: Linux 5.10.0-5mx-amd64 #1 SMP Debian 5.10.26-1~mx19+1 (2021-04-01) x86_64 Binary: 64bit
10.10.21 18:35:49 Info Using hardware aes
10.10.21 18:35:49 PulseAudio Debug connected to pulse audio server -
10.10.21 18:35:50 ClientUI Info OpenGL Info: LibGL, Vendor: NVIDIA Corporation, Renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2, Version: 4.6.0 NVIDIA 470.63.01
10.10.21 18:35:50 Addons Info Checking for addon updates…
10.10.21 18:35:50 Info *** Time [MAINWINDOW]: 197
10.10.21 18:35:50 Info *** Time [INIT]: 198
10.10.21 18:35:50 ClientUI Info Failed to init text to speech engine
10.10.21 18:35:50 ClientUI Info Qt version: 5.12.1
10.10.21 18:35:50 ClientUI Info Using configuration location: /home/yannik/.ts3client/settings.db
10.10.21 18:35:50 Addon Info Addon up to date.
10.10.21 18:35:50 Addon Info Addon up to date.
10.10.21 18:35:50 Bookmarks Info Collecting autoconnect bookmarks
10.10.21 18:35:50 ClientUI Info Last update check was: So. Okt. 10 19:18:30 2021
10.10.21 18:35:50 Info Statistics report: Not yet, next report on Fr. Okt. 29 18:33:05 2021
10.10.21 18:35:50 Addon Info Addon up to date.
10.10.21 18:35:51 Newsticker Info Newsticker next check: So. Okt. 10 21:14:46 2021 GMT
10.10.21 18:35:53 ClientUI Info Connect to server: 192.168.2.13
10.10.21 18:35:53 ClientUI Info Initiating connection: 192.168.2.13:9987
10.10.21 18:35:53 ClientUI Info Connect status: Connecting
10.10.21 18:35:53 PktHandler Devel Puzzle solve time: 7
10.10.21 18:35:53 ClientUI Info Connect status: Connected
10.10.21 18:35:53 ClientUI Info Connect status: Establishing connection
10.10.21 18:35:53 ClientUI Info Connect status: Connection established
10.10.21 18:36:23 PulseAudio Debug Underflow occurred on device ts3.pa.dummy.playbackdefault - -

If you need more information just ask.
Thanks in advance.

PS: I dont think the Pulse Audio Underflow has something to do with it as the microphone stopped working before this came up.

twitch instagram twitter facebook