Is there any way left to assign Admin Server Query to a voice user?

I’ve always viewed Admin Server Query as using root on a Linux box. Never recommended because of the damage you might do, but perfectly safe when you are careful.

I know the feature has been outright blocked. This applies to the SSH/Telnet Server Query consoles, and it also applies to query apps like YaTQA… the same error (512) gets thrown whenever you try to assign a voice user ASQ.

The only thing I could think of doing was to install a dummy server using an older version of TeamSpeak Server, assign it that way, then upgrade to a newer version of the server. However, that doesn’t seem to work either, due to the licensing expiration every so often.

I’ve even tried modifying the SQLite database file directly (backed up, obviously). I’m no expert on SQL, but when I modified group_server_to_client to assign Admin Server Query to my Teamspeak identity, the server outright ignored it.

Perhaps I changed the wrong thing. Everything still works, but the server totally disregarded that entry…

I know this question has been asked many times on the forum before me, but none of the previous answers have been very helpful. I must stress: It does not work when you try using serverquery

So, for science - is there any way whatsoever that could be used to assign the group to a voice client?

The thing is when something isn’t working and it’s not recommended or even outright blocked, maybe you shouldn’t make it happen?

Also, as name suggests, it’s ”Server Admin Query”, not “Server Admin”. You DO NOT use it for normal clients just as you don’t use root on Unix (unless you really need to, know what might go wrong and stop using it after you finish what you needed to do).

1 Like

…so you can paraphrase the content of people’s posts. Did you bother to read the question?

It is my server and I should be able to do as I please.

This is why I hate the teamspeak community, so little help and so much anger and hostility

As you’ve already mentioned above there’re lots of threads about this question.

It’s not supported by TeamSpeak and nonsense to assign query permissions to clients.
The extra permissions you get are only relevant for global/instance settings.

However instead of calling the community unhelpful you should probably try to use the search function.

It’s still unsupported and nonsense for any server and it’s no use for “science”.

1 Like

My search function works quite well, as I already found that post. Thank you for suggesting it, but that wasn’t the point of my question. That method creates a new group, which obviously then becomes not the Admin Server Query group.

Call me “power hungry” or “nonsense” if you like, but I want to have unrestricted access to my own server, without having to use that god awful excuse for a command line, or open up a program like YaTQA every time I want to use server query. Is that such an unrealistic thing to want??

YES!

WRONG! (kinda)

The method described by @FakE i sthe only possible!
A server query group is meant for the server query. Not for a client. Thus it can NOT be assigned to a client. Thus a copy is needed to be able to assign it!

But the copy is effectively the same as the original but with a different type. THE TYPE ISTHE ONLY DIFFERENCE and this difference is needed to be able to assign it!

2 Likes

Well he was a little faster responding than me… :open_mouth:


While reading the thread I mentioned above you will notice it’s not possible to assign a query group to a client (anymore).

Copying the group will copy all the (highest) permissions as well.

There’s no different way to assign yourself “higher/more” permissions (power) than copying this group and assigning it to yourself.

Aye…
That’s exactly what you will own after copying and assigning the group to yourself.

And yeah… it’s still nonsense.

2 Likes

I think it would theoretically be possible to install a really old server. Assign the group and then update the server.
I am really not sure about this but I think it copied the group to a server group at some point and would virtually be the same as just copying the group yourself.
But as the old server won’t start due to outdated licenses the method explained by FakE is the only one.

Yeah pretty much what I thought. I guess I could spin up a VM and play around with the date/time while offline, then install and run an older server version that way.

Might work…

I can’t help it, I like poking things to see if they break sometimes!

This won’t work / result in what you want.
Even if you get an old server version started. There is no way in keeping the original group after updating the server…

Maybe… maybe not. I’ve seen it working in this way.

A friend of mine runs a server that’s been on the go for a long time. They had ASQ assigned to their user identity, and they have retained the group assignment, update after update. Because the database shouldn’t change its values just because the server version is newer, unless there’s some sort of check that takes place…

But if there was, then my friend would surely have lost their ASQ upon update, no?

If I give this a go I’ll let you know what happens

twitch instagram twitter facebook